Sandisk 1Tb no longer usable or visible

Someone gave me a nice Sandisk 1Tb to backup data on.

Then one day, while using Rufus to write KDE Neon .iso upon, forgot that the 1Tb disk was still plugged in, and it overwrote on it (instead of my regular one for this purpose). By the time i noticed, it was too late.

Now i can’t restore data, nor use it for anything on Windows.
Even KDE Neon will not even see it plugged in (tried a couple of usb ports).

Rufus is like dd . It will overwrite everything on the disk with the raw disk image that Rufus was told to write.
I am afraid the data on it are lost… unless you had a backup or want to pay a lot of money .
You need to reformat it
Use gparted, give it a partition table (either msdos or gpt)
then partition it the way you want , and format each partition to whatever filesystem type you want ( eg ext4 or ntfs or…)

1 Like

The perils of playing with Linux from a Windows install!!! A reformat and partition table, is about your only option. I play with Linux, but only from a VM with my Windows install, although I will dual-boot Windows and LInux , on older PC’s. Good luck!!!

1 Like

Okay, have Gparted installed now.

But it won’t “see” the usb device.

Have tried plugging it in three different usb ports.

Reboot made me lie.
Here it is:

Problem is, even if it is unlocked on the Windows side, still cannot copy files to it.

Would just like to erase the drive and use it.

If the SansDisk is ext4 Windows will never recognize the drive.

1 Like

Haven’t found a way to wipe the disk under Windows or Linux.

Can gparted see the disk?
If not
are you running gparted in Linux?
Try putting gparted on a usb drive and booting it. Then all the disks will be
If you can get gparted to see the disk, gparted will wipe it… just delete all the partitions.

If all else fails, do from linux
dd if=/dev/null of=diskname
and you had better get diskname right or you will wipe another disk !!!
That will wipe the whole disk clean… all zeros.

1 Like

Never did that before.

Suppose Rufus could install it to another Sandisk.

Yeah, or you can just copy it with dd in linux
dd if=name.iso of=nameofusbdisk
again, get the nameofusbdisk right… or dd will write on something else!!!
Use lsblk to find the names of your disks , then plug in the usb drive, then use lsblk again, and the extra disk listed will be the usb drive… that is the safe way to find the right disk name.

1 Like

On Linux start a watching thread for dmesg:

sudo dmesg -w

After that plug in your SSD into an USB port.

Do you see something like “…disk attached”?
Or what happens in that 2-3 second after you plugged the SSD?

IF hardware works OK, you still have small chance to get something back.
I assume, what Rufus wrote to that disk is smaller than 1TB, so hopefully did not overwrite everything.
This hope for you is Photorec.
Photorec reads the disk content directly regardless of the underlying filesystem.
You may find and rescue some of your documents, pictures.
Many cases the file name is lost, you will have to find out what it was called.


OK, I kept reading, so data rescue is not your main goal.
Show us please the output of dmesg -w right after you plugged in your SSD!

1 Like

You will more than likely have to boot the pc with gparted from a usb or cd, that way all drives are unmounted. If you know how to use diskpart with Windows, that can also be used or try to recover your data as @kovacslt has posted.

1 Like

Long lines basically like this:


That does not look good.

Can you check the SMART?
Something like
sudo smartctl -A /dev/sdb

Maybe you need to install smartmontools package.

1 Like

smartctl 7.2 2020-12-30 r5155 [x86_64-linux-6.5.0-35-generic] (local build)
Copyright (C) 2002-20, Bruce Allen, Christian Franke,

/dev/sdb: Unknown USB bridge [0x0781:0x55ae (0x3001)]
Please specify device type with the -d option.

Use smartctl -h to get a usage summary

1 Like

Looks like tha case in which you have the SSD does not support SMART, so we can’t check…

Still there are things you can try:

sudo dd if=/dev/zero of=/dev/sdb bs=1K count=8

That zeroes the first 8kB of the disk, so partitions will be lost. The data physically (hopefully not overwritten by Rufus previously) will stay, so you’ll have a chance to run Photorec, and recover some of your files.

After this zeroing is done, unplug the disk, and replug it.
It will look like never partitioned brand new disk, but don’t forget, some of your data may be there!
So replug, and see if it behaves normally.

When zeroing, double check /dev/sdb refers to your disk in question!
This is an irreversible operation!

you can run badblocks to gain information, wether there are bad sectors?
sudo badblocks -sv /dev/sdb
This will perform a read-only check, and provides verbose report.
This will probably take a long time to finish.


OK Laszlo, you know more about this than me… I never thought of zeroing part of the disk.
You had better take over.


I had my hard times to learn it :grin:


This may be a bit left field

Ok you need windows to eun it, but its saved my bacon several times and you could go for the free version to see if it will work

1 Like