Shutter screenshot tool editing option in Linux Mint 19.2

I tried the workaround to activate the Edit button in shutter but libgoo-canvas-perl is not available. Has anyone been successful in restoring Edit?

which workaround did you try?

1 Like

Firstly, welcome to the community.
I am sorry I really don’t understand what you are asking, as you are starting with a statement then asking a question. Please could you be more specific and supply more detail, thank you


which version of mint are you trying to do this in?

I am using 19.2. Sorry I missed the reference but here it is


are you getting some kind of error?

1 Like

Here is the complete response to the suggested workaround. “Package libgoo-canvas-perl is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source.
E: Package ‘libgoo-canvas-perl’ has no installation candidate.”

This means my effort was unsuccessful, hence I ask the question - has anyone else been successfull.?.

it can be hard to nearly impossible to help fix something without knowing the steps you took to get to the unsuccessful result you have. asking questions is the way other community members (myself included) try and do that. based on your most recent answer, i think i have a way to help. but if all you want is an answer to the question “has anyone been successful?” i can certainly leave it at that :slight_smile:


What is the output of:

apt-cache search libgoo-canvas-perl

1 Like
ken@ThinkPad-T410:~$ apt=cache search libgoo-canvas-perl
usage: search [arguments] [options]
         for text
         in directory
         -c | --case-sensitive
         -s | --show-filenames-only

ken@ThinkPad-T410:~$ apt-cache search libgoo-canvas-perl

Yes, I did the workaround successfully several months ago, but sorry, I can’t recall exactly what I used. I see no problem with it now, after I upped to Mint19.2-MATE. As I did a clean install(of 19.2), I reinstalled Shutter(0.94,Rev.1290), and Edit functions properly.You might want to look into “Flameshot”-in most pkg mgrs, if you-re still having problems with Shutter.


Thank you for the suggestion. The reviews look really good. It is a pity you do not remember your actual workaround - it may have been totally different to the one I tried.

Wait a sec! Mint 19 is based on Ubuntu 18.04. Which means this libgoo-canvas-pearl is not available in either of Ubuntu 18.04 and Mint 19.

What you need to do is to download the DEB file of this library directly. You’ll find the link in this article under Ubuntu section.


It was your article that I was using and you may remember that near the end you provided a different option for Linux Mint. It was this shortened procedure that I followed. and produced what is obviously a confirmation of your sttement that libgoo-canvas-perl is not available.


I am afraid that as a very recent Newbie to Linux Mint I have no idea what this is all about.

the link you posted says you need to have three different packages installed (instead of the one that was needed for linux mint 17 and 18: libgoo-canvas-perl) to fix the edit option in mint 19. the first is libgoocanvas-common. after you click that link, you should get a window offering to open the file with GDebi Package Installer (see below). make sure the button is selected in front of “Open with” and then click ok.

that should open the Package Installer and you would then click the “Install Package” button in the lower right-hand corner.

you need to do the same for the other two packages (libgoocanvas3 and libgoo-canvas-perl) listed on that page under " Enable edit option in Shutter in Ubuntu 18.04 & Mint 19".

hopefully that will get you sorted. i’m on mint 18.3 myself so i can’t verify, but if @abhishek says it works i tend to believe :alien:


I don’t appear o have “GDebi Package Installer” only Url Handler Script is offered.

can you go ahead and save the file?

1 Like