Systemd weirdness in Fedora - AND - Red Hat EL 8

OK - there may be some general hate leveled at systemd, and distros devoted just to its absence…

It’s here, to stay, aint no getting away from it. The writing was on the wall when Sun still owned Solaris, and they were heavily pushing “SMF” (system management framework, to replace SystemV init).

Anyway - I’ve always found the “systemd --user OPERATOR SERVCE” functionality - VERY useful - works FLAWLESSLY on every Debian and Ubuntu I’ve tried it on…


Here’s my problem :
I want Resilio Sync (RSL or resiliosync) to run for my user, when a computer boots up.
I do this via:
sudo loginctl enable-linger $USERNAME
… sweet - so far, so good…

I enable it to run for my username with “systemd --user enable $SERVICE” and I can start it via “systemd --user start $SERVICE” (note sudo is not needed, in fact sudo will probably break this) - and that works a treat on Debian and Ubuntu…
But Red Hat and Fedora? NO!
This works:
systemctl --user start resilio-sync.service

- but this doesn’t :

╭─x@fenriz ~/ResilioSync/bigguns/binaries/LinuxSOE  
╰─➤  systemctl --user enable resilio-sync.service
Unit /usr/lib/systemd/user/resilio-sync.service is added as a dependency to a non-existent unit

non-existent unit

I don’t even know WTF that means! But the nutshell is that it DOESN’T WORK like on Debian and Ubuntu. EXACT same result on RHEL 8 (x2) and Fedora 35.

I"m google-fu’ing the f–k out of the intert00bs to find an answer, and haven’t hit anything yet…

So here’s the FIX - but - it shouldn’t have to BE LIKE THIS! Why is it so??? (I exclaim in anguish and rage) :

sudo vi ~/.config/systemd/user/

Find “[Install]” stanza :


Do this :



╭─x@rhel8000 ~  
╰─➤  systemctl --user enable resilio-sync.service

Reboot (to verify it works over reboots) :

╭─x@rhel8000 ~  
╰─➤  systemctl --user status resilio-sync.service 
● resilio-sync.service - Resilio Sync service
   Loaded: loaded (/usr/lib/systemd/user/resilio-sync.service; enabled; vendor preset: enabled)
   Active: active (running) since Thu 2022-03-31 11:44:08 AWST; 7min ago
  Process: 1120 ExecStartPost=/bin/sleep 1 (code=exited, status=0/SUCCESS)
  Process: 1108 ExecStart=/usr/bin/rslsync --config /home/x/.config/resilio-sync/config.json (code=exited, status=0/SUCCESS)
  Process: 1101 ExecStartPre=/etc/resilio-sync/ (code=exited, status=0/SUCCESS)
 Main PID: 1119 (rslsync)
   CGroup: /user.slice/user-1000.slice/user@1000.service/resilio-sync.service
           └─1119 /usr/bin/rslsync --config /home/x/.config/resilio-sync/config.json

Mar 31 11:44:06 rhel8000 systemd[1057]: Starting Resilio Sync service...
Mar 31 11:44:08 rhel8000 systemd[1057]: Started Resilio Sync service.

DIRTY STEENKING “ENTERPRISE” LINUX :angry: :angry: :angry: :grimacing: :grimacing: :grimacing: :nauseated_face: :nauseated_face: :nauseated_face:

That’s how I fixed it anyway - but it’s a PITA to have to do it on multiple computers… I’m also not convinced that’s the “right answer” to this problem either…

I fully expect this issue will probably also exist on OEL 8 (Orrible Enterprise Linux) and whatever it is that’s replacing CentOS (Rocky?).

The right answer is to avoid EL.
What makes these corporate types think that if you pay for something it is better? It is actually worse and then you pay for the service to fix it.
The free version usually comes ready-fixed.

Aside from that systemd is a minefield for bugs because it is too complex


and bloated… the more bloated something is - the more vulnerable and unmanageable it becomes…

unavoidable in the corporate world unfortunately…

@nevj did you work for the Commonwealth when you were a wool scientist? CSIRO?

In 2017 I did a short term contract (I was hoping it would become long term) with the Bureau of Meteorology, they were all Red Hat, everywhere, the odd bit of CentOS or even Oracle Linux, and actual desktop Linux users running either Red Hat EL desktop, or Fedora, they also had a tiny little AIX footprint, and whatever Linux O/S Cray run on their supercomputers (I think it’s RHEL based)… Tell ya what - I’d 10,000x rather using anything Linux, than MS Windows… The CSIRO Pawsey supercomputer located here in Perth, is also Cray and running something related to Red Hat… it’s inescapable… Amazon Linux is based on Red Hat…

The last time I used UNIX in a Commonwealth department, was early 1994, Department of Veterans Affairs, at one of the Repat hospitals, DG-UX on an 88010 DG AViiON…

So I guess I better get used to RHEL… It’s my job…

Yes that is me…retired in 1998

In CSiRO we were actually able to get rid of the whole CSIRONET computer system, and other corporate systems like DEC VMS in some Divisions. When I finished up, most Divisions had Unix servers … BSD in Sun systems mostly. I was involved in a lot of battles over that shift. It was not a total win, Microsoft had some strongholds,.

So you can win sometimes… especially if actual users of computers have the say


1 Like

Maybe, this sheds some light on the issue. I did not find any indication on that WantedBy part being different, though, when skimming through the document.

I’ve mostly gotten by in life so far, including 25+ years UNIX and Linux sysadmin, without having to RTFM (the one time I nearly did - well - that’s another story, and it was mainframe, not UNIX or Linux).

My issues are with RHEL 8 actuall (and I think my Fedora 35 is previewing stuff IBM/RHEL may include in RHEL 9).

I might actually checkout if this issue happens on RHEL7… I did run RSL on Amazon Linux in AWS about 3 years ago, till I got the bill ($35 for a month - I only took it up 'cause I got emails about free usage tier, and ONLY used “free usage tier” stuff) and I’m pretty sure that version of AMZN Linux was based on RHEL 7 - and I seem to remember “systemd --user blah blah” worked the same as it does on Debian and Ubuntu…

For shits and giggles, I might spin up an REL 7 and an OEL 7 VM and check it out… I think I actually have some VHD’s saved on my NAS… If I can remember the passwords…

I like it.
We used to think that to use Unix one had to have a shelf full of O’Reilly books. Not the case today. Your skill is in researching how to do things in computers, not in a library of information.

Mainframes were another matter. Did you use IBM JCL? It was about as intuitive as assembler language, in fact it even looked like assembler. I think I still have my JCL manual. Couldnt live without it in the 1960’s


92/93 : I was backfilling as a mainframe operator, it was all new to me - most of the job was trained monkey stuff… but one night, a Tuesday if I remember, about 8 or 9 pm, I did something wrong, and ended up with TWO syslogB instead of syslogA and syslogB! I seem to recall IBM ported this “feature” over to AIX too (I noticed this many years later - infact AIX has a command “mksysa” and “mksysb” I think) - so long ago - I can’t remember if MVS was case sensitive or not - might have been all caps “SYSLOGB” and “SYSLOGA”.

Anyway - one WHOLE WALL of the operations console area, was BOOKSHELVES, containing ALL the system manuals, about 15 feet wide, and about 4 feet high, MVS manuals JCL/JES2, CICS, IMS… blah blah blah… I looked at that MASSIVE WALL of documenation, without a single clue where to start looking, and my guts sank, and panic started to set in…

Anyway, managed to get hold of the operations manager, and he dialled in, took a look at it - couldn’t figure out how I’d managed to screw something up, so simple, but said it should probably fix itself the following week (and it did).

I was much better with PCs and Novell Netware and even the dabbling in UNIX I did (DG-UX).

Edit : my ResilioSync install has a bunch of manual CLI-fu steps anyway - so a variation to get it running on RPM based distros won’t be too tricky… I’m like about 87% edging towards running Fedora 35 on my gaming desktop… it’s running Ubuntu 20.04 but it’s a bit dodgy, there’s some things wrong with apt on it - and probably easier to format the sucker and rebuild from scratch…

1 Like

Just tried cloning my RHEL 8 on hardware from 256 to 512 GB mSATA SSD (used dd to clone, then tried gparted to grow) - but something went wrong with it… I could always go back to the old one - but - far as I’m concerned - easier to just do a re-install from scratch…

Gigabyte Brix - dual core Celeron, 16 GB DDR3, 512 mSATA SSD…

OK - I am persisting with Fedora - and still intend to wipe my gaming desktop (ubuntu 20) and install Fedora (probably 36) - but I just remembered one gotcha with Red Hat based distros : the “rename” command is utter rubbish. In Debian derived distros, the “rename” command is really perl, and you can used regex to rename files in bulk (and do simple things like remove space chars in filenames, and the worst CRIME in filenaming is adding illegal characters like { } and [ ] and ( ) and % and @ and & - i.e. stuff the shell might interpret some other unpredictable way - and - some copy operations will barf on, and some operating systems will shit themselves (like Android on Samsung Galaxy junk)…

TL;DR I cannot live without the PERL / CPAN version of rename in my life.

So - summary : to address this on Fedora :

sudo dnf install prename
sudo mv /usr/bin/rename /usr/bin/_rename
sudo ln -s /usr/bin/prename /usr/bin/rename

done… yeah - I could do that in my profile (.zshrc in my case) - but then I’d maybe have to log out of my X11 session to reread my profile (note : I didn’t have to - just had to fire up another terminal).

But I prefer above - however - a yum update might screw with my rename of rename to _rename (sic).

* in my fantasy dystopia run by me, as a mostly benevolent dictatorship, polluting filenames with illegal characters like that would be a capital offence…

1 Like

Despite the systemd weirdness - the Fedora 35 build on my Ryzen Thinkpad has stood the test of time (just coming up to a month)…

Wiped my Ubuntu 20.04 system this morning, installed Fedora 36 (beta), took me two goes - something wrong with how it wrote my UEFI boot entry… so far so good…

Second attempt seems “all go” - not quite ready to start syncing across all my user data (my data) - followed some guide about how to get NVidia proprietary drivers working in Fedora 36 - and - thanks - THEY FUCKED it over completely - installed some grub entry that ignored my LUKS encrypted “/”…

So - back to tried and true Fedora 35 - all good… it’s now 10:30 pm Sunday - and my Fedora 35 destkop machine is setup ready to do what my Ubuntu 20.04 machine was doing… and I’ll wait until a suitable time arrives, that Fedora 36 doesn’t BORK on NVidia stuff, to update to Fedora 36 (e.g. on my Thinkpad - who knows by then I might have forked out for an AMD GPU - the “out of the box” with AMD open source Radeon makes NVidia look like a shitty Riva TNT AGP card from the late 1990s).

Kinda bizarre - my “bread and butter” is basically Red Hat systems, for headless servers, I eat, breathe, and sleep that shit, but on desktops I’m a bit rusty (but I did actually used to do “desktop support” for seismic geologist workstations, running RHEL 3 or 4, with Quadro FX GPU’s and a shit ton of RAM (hey - 16 GB of RAM in 2007 was still a SHIT ton for a server - these guys had that on their desktop Linux machine! Back when SMP meant TWO physical Opteron 64 bit AMD’s and not muliple cores on a single die).

Steam installed without issues (a simple “sudo dnf install steam” away)…


Why are desktops any different?
I think of a server as just a desktop with a few extra daemons running and maybe not bothering with a console.
Sure they have raid arrays and run databases

More questions. Why fedora? It obviously does what you want and I know Ubuntu has fallen in a hole, but there are probably half a dozen good alternatives. I know fedora has a good image in the scientific world.

And if you really want a super gaming desktop, spend some $$ on ram. A s much as you can get onto the motherboard. Ram is cheap today.
Graphics card … I would like that Radeon card… image processing, not games… lots of rendering.

I like success stories even computer ones , … its a bit like the appeal of detective stories…a triumph of order over chaos.


I agree - but headless server is an order of magnitude easier to support than desktop… and jesus H f–king christ, I am glad - I HATED desktop support - good riddance to it… :smiley: Each to their own - for me? I support my desktop of choice, and that’s any of XFCE, Gnome 3 or 4, and OS X…

I guess its a matter of too much diversity in desktops.

Have you tried the dual desktop feature in Fedora?
I have read that it allows you to install 2 DE’s in a way which prevents them interfering and allows you to switch between them. Is that correct?

Sorry - I have no idea about that feature… I might look it up - I recently (i.e. last ~12 months) tried to take a look at Budgie desktop on Ubuntu, didn’t like it - but it left bits and pieces of itself “orphaned” in my somewhat Vanilla Ubuntu 20.04 Gnome 3.3x DE…

I’m very happy with Gnome 4.x - I’ve recently suffered (because there’s always pain) from distro-hopping, and tried several distros with KDE, and didn’t like it one single bit… Also tried Pantheon (elementary’s desktop)…

I really want to like Pantheon, it looks nice, but, elementary lock it down too tight for my taste.

my favourite DE’s :

  1. Gnome 4.x
  2. Gnome 3.3x
  3. XFCE 4.x

Not remotely interested in tiling WM’s…

Yes, that is the problem. I tried KDE on top of Debian/Xfce once, and they clashed … like several apps did not work. Did a purge of kde, but it did not remove everything. Had heaps of packag3s to hand remove.

That is the issue only Fedora is supposed address. Have a look when you get time… I would like to know how it does it.

My preference is Xfce, followed by Gnome or Budgie
Pantheon is worth a look., and some of the otber lighter DE’ s like Mate

1 Like

1 Like

What cheeses me off (putting it mildly) is the ancient lo-fi versions of XFCE you get on Raspbian, compared to e.g. XFCE version on Xubuntu - it seems major revision levels ahead (it’s only minor revision levels ahead)… i.e. default XFCE on debian seems okay, but not as spiffy looking as XFCE on Xubuntu (or even Manjaro).

I’ve also tried Mate and Cinnamon and didn’t enjoy either… I LOATHE the Pi Foundation’s “Pixel” desktop, and that’s LXDE, and I already kinda hated that DE before I ever tried Pixel on a Pi… So when I build out one of my Pi’s for a desktop experience (I have 3 x Pi4’s) if it’s going to be Raspbian (or as they have now rebranded it: RaspiOS) I usually go for the “lite” version and install XFCE - but - it turns out that Gnome is VERY usable on the Pi4 (with 8 GB) so I usually go for the latest Ubuntu desktop on Pi4.

Been trying to get my gutted Mac SE/30 setup with a Pi3 to look like a classic MacOS (i.e. like System 6, 7, 8 or 9)… Ideally I’d like to force it to go monochrome and System 6. Bryan Lunduke is one of my favourite “pundits” for Linux and OSS related stuff :

I had mixed success getting this to work on my XFCE Pi3 running Raspbian Bullseye… I actually bought a VGA hat for it - but having more success using a basic HDMI > VGA adaptor… The 4:3 display I’ve crowbar’d inside the SE/30 chassis is an 8" TV with built in RCA and VGA connectors (couldn’t get a TRRS jack to work with the Pi3)… Why would I do that? Run a fake Classic Mac? For shits n’ giggles and the nostalgia :smiley:

I really would prefer the System6 or 7 look… I guess I could get Executor or Basilisk II emulation going, but I don’t want to emulate, I want to simulate…

That is the Debian fixed release problem.
You need a rolling release distro to get up to date Xfce, or anything.
Is there a rolling release distro for Pi?

1 Like