This computer has only 8.1 gb ubuntu error

Hi guys I have a kinda weird situation here

I have a new HP 15s dy3xxxx laptop running win10 preinstalled and trying to dual boot it with linux i.e ubuntu 20.04 LTS

I am following this article
[Beginners Guide To Install Windows 10 With Ubuntu in Dual Boot](https://Install ubuntu on win 10)

the bios mode is UEFI and I have created a bootable drive as shown in the article
I have disabled secure boot from bios, hibernate and quick start in windows power options is also disabled.
The hard drive has AHCI controller

When I try to install firstly I do not get install ubuntu on the screen

I do a live boot and try installing from there and this is the error I get

When I run gparted from live boot it only lists the current plugged in usb
I ran this command from live boot sudo lshw -class storage -class disk which lists the hard-drive

I have gone through all the internet but could not find a solution please help!

1 Like

Could you take a screenshot of the list of devices in gParted, that shows only the USB?

Additionally, please add a little OS information by posting the output of the following command:

inxi -Fxmz

You can run that command on a live disk, that has this program pre-installed or you may need to temporarily install it onto your live device:

apt install -y --install-suggests inxi 

If that does not work on a pure live system, you might want to create a live system with persistent storage:

2 Likes

gparted screen shot

System: Kernel: 5.8.0-43-generic x86_64 bits: 64 compiler: N/A Desktop: Gnome 3.36.4
Distro: Ubuntu 20.04.2 LTS (Focal Fossa)
Machine: Type: Laptop System: HP product: HP Laptop 15s-dy3xxx v: Type1ProductConfigId serial:
Mobo: HP model: 881D v: 50.24 serial: UEFI: Insyde v: F.43 date: 03/31/2021
Memory: RAM: total: 7.54 GiB used: 1.17 GiB (15.5%)
RAM Report: permissions: Unable to run dmidecode. Root privileges required.
CPU: Topology: Dual Core model: 11th Gen Intel Core i3-1115G4 bits: 64 type: MT MCP arch: Tiger Lake rev: 1
L2 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23961
Speed: 909 MHz min/max: 400/4100 MHz Core speeds (MHz): 1: 1069 2: 789 3: 1221 4: 1076
Graphics: Device-1: Intel vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 0000:00:02.0
Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: fbdev,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT2) v: 4.6 Mesa 20.2.6 direct render: Yes
Drives: Local Storage: total: 7.50 GiB used: 3.07 GiB (40.9%)
ID-1: /dev/sda type: USB model: N/A size: 7.50 GiB
RAID: Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd v: 0.6 bus ID: 0000:00:0e.0
Partition: ID-1: / size: 3.77 GiB used: 395.4 MiB (10.2%) fs: overlay source: ERR-102

1 Like

In the screenshot, you have selected the USB drive or the DVD, not your computer’s hard disk. On the top right, select the correct disk.

2 Likes

There is nothing to select there only one option which is already selected

1 Like


this is the info related to hard disk i found in bios

1 Like

https://itectec.com/ubuntu/ubuntu-ubuntu-20-04-doesnt-recognise-hard-drive/

1 Like

hi akito
I have gone through all these links and one thing which is common is change IDE controller to AHCI but w.r.t. the drive info i have attached above it already has a AHCI controller

And also there is no way to change to any other setting in BIOS. This is the bottleneck which I am facing. I am meeting every condition to install but still this error.

1 Like

can u create a new partion and try?
i think it will worku can make a new partion of 10gb atleast or more as per ur choice
i recommend 100 or more for comfortable use
because it says 8.9 gb is requires

I don’t see here your HDD.
What other settings do you have in the BIOS?
Can you switch off NVME in the BIOS?

Surely?
Can you show the output of that command?

do this it will work @majestic_flame

How on earth could he create a new partition on a disk, which the live systems kernel doesn’t even “see”?
It’s not that there’s not enough room on the disk, but the disk seems to be absent.

1 Like

I do highly doubt. But trying it won’t cause any loss :smiley:

he can do that in windows
:slight_smile:

What’s the point of having a FAT-based or NTFS partition on Linux? Only makes sense for shared space, not as an installation target.

1 Like

@TypeHrishi, will that magically make the physical drive visible to the Linux kernel?

1 Like

@Akito, I suspect missing kernel support for something in that machine.
Probably I’d try something with the most recent kernel.
I’d also share lspci -v output after running update-pciids.
Maybe someone will have an idea which HW requires what firmware or kernel version?

Hi @TypeHrishi
The problem is it is trying to install in the live usb itself 8.1 gb is the size of live usb
I already have a 100GB partition created from windows on hard-drive which shows unallocated in windows disk management

So no it wont work, the primary issue is hard disk is not detected by live usb.

No option to turn on/off cannot select anything