Thunderbird 60.9.0 Gmail password workaround

after a discussion with @JHarp, i also found that thunderbird 60.9.0 was refusing to accept my gmail account and password. according to this it was a change in google’s oauth process. the stated fix was:

Changing “general.useragent.compatMode.firefox” preference to true fixes the issue, google authentication works again.

i originally found that github link from a thread on the Thunderbid subreddit. i was unsure how to navigate to that particular preference, but KrillDerelictLeeward’s kind reply was enough to get me started in the right direction.

at the top right of thunderbird i clicked on the three lines. in the right-hand column i went to Preferences and then Preferences again in the menu that popped up. in the Thunderbird Preferences window, there is an Advanced tab at the top. under the Advanced tab there is a General tab. at the bottom of the General tab there is a Config Editor… button. after clicking that and accepting the risk(!) of voiding my warranty, i typed “useragent” (without quotes) into the search box. i double-clicked on the value field of general.useragent.compatMode.firefox to change it from false to true and then i was able to add my gmail to thunderbird.

for those who are a bit more visually oriented like me:
three lines (menu) -> Preferences -> Preferences -> Advanced tab -> General tab -> Config Editor… -> accept risk(!) -> useragent search -> double-click value field of general.useragent.compatMode.firefox for true.

according to this and this a fix is already in place for 60.9.1, but i figured i would share this in case anyone else was having issues now before that update rolls out to the various distros.

5 Likes

Thanks cordx,
I applied your fix and it has survived two restarts of Thunderbird, and one restart of the computer. Here’s hoping it will be good til we get the update.

i’m glad to hear that worked for you.

I backup my Pep 10 every month or so in Systemback, but found just having a fresh install with codecs on no drivers or apps installed is the way to go. Anyway I’m digressing. When I installed Thunderbird I too had this problem. Apparently Google does not trust Thunderbird anymore, yet they mention it in their instruction dialogue. Yes this work around works. If you are using Firefox, click into your account as in your Avatar and go to security and turn untrusted apps to on. Eventually after logging into your Gmail account via Thunderbird, you will see inbox pop up. :grinning:

1 Like

one of the reasons i ended up using the workaround on the thunderbird side was that i originally tried setting up an app password in google security like i had to do for my phone. i just looked in there and don’t see anything after a couple of scans about untrusted apps. is it maybe hidden in a menu or something?

Untrusted is on desktop version in Firefox I don’t know about phones. Just click your avatar it’s in security settings.

Thank you!! I am back on T-Bird instead of using the Google Mail site.

2 Likes