Timeshift problem


#1

Today I received the following errors:
" [[Firmware Bug]: TSC_DEADLINE disabled due to Errata ]"
" [Not enough space in /var/cache/apt/archives/]"
and a few others that finally indicated that my /dev/sda1 was full.
Turns out that Timeshift ate all available memory and I couldn’t logon to my system.
Here’s an article I found after I deleted the Timeshift folder and was able to log back on.
https://bugs.launchpad.net/ubuntu/+bug/1738065
Hope this info is of some use to you all.
Best,
Jim
(Linux Mint Cinnamon 19 & recently playing with Manjaro on an old laptop)


#2

Hi I’ve been using Timeshift a while now on Linux Mint 18.3 with no problems. The snapshots can be over a gig in size so I normally delete the older ones and keep the last 2 I did as backup


#3

Thanks for the reply.
I too had been using Timeshift for a long time with no problems - and it saved me one time. I’m not sure that I was using it correctly. About once a week I would create a new ‘O’ backup (using Rsync) and would delete the older ‘O’ and all the previous ‘D’ backups along with the logs.
I have 20GB allocated to /dev/sda1. When the problem occurred, Timeshift used 9.4GB - all that was remaining and there was only one folder under ‘snapshots’ with the current date.
I tried removing Timeshift, using Catfish to search for anything called Timeshift and shapshot. Nothing was left. I ran autoremove and autoclean. When I reloaded Timeshift, it once again used all the remaining memory (over 9GB) on my first attempt at an ‘O’ backup. I removed the program and files again.
Best of luck,
Jim


#4

Hi I’ve been using it since it became available on Mint. I have set the daily number to 1. I tend to do a Timeshift before every update so that if anything does go wrong I can role back. If nothing does go wrong then I delete every other created point leaving only the last one. I haven’t had a problem with it doing it this way. I do use an SSD (internal) so I don’t know if it would be different on a “normal” hard drive.


#5

this is pretty much how i use it as well. in addition, i also check if i have a recent snapshot before installing anything i am not familiar with just in case.

i do tend to let the dailies stack up though. i just checked and i have 55 of them taking up about 38 gb of space. your method probably makes more sense, but in the back of my mind i keep hearing a warning about “what if that update works for a couple of days before it borks…” :slight_smile: all in all not a whole lot of space taken up after about 10 weeks with this new install and i like the peace of mind knowing that i can revert if the need arises.


#6

As a followup, I have reinstalled Timeshift and switched the location of the RSYNC backups to a larger partition (SDA6 which has 615GB available). I have not had the problem reoccur. Jim


#7

i’m glad to hear you found a solution :slight_smile:


#8

Thanks for letting us know and the solution you found. It will help others in our community :+1::+1:


#9

Consider accepting a reply as a solution within the forum, to finally clarify.


#10

I have found a work-around that seems to be working so far. As far as I know, there is no solution yet.
Here’s another link: https://github.com/teejee2008/timeshift/issues/332#issue-370534345


#11

Hey just as a crazy aside: I had Timeshift fail (or rather I failed Timeshift) by using a gui program called “Stacer”. (I’m sure It’s foss still has an article about it.) Most of what it does is easy enough to do in the terminal: Clearing out package logs, crash reports etc. But it’s a nice alternative for new users who are still wary of the bash line.

A few months ago I re-installed the lastest version of Stacer to play with a much improved interface. And it found about 15GB of (mostly as it turned out) useless files, which I then deleted.

A few days later I wanted to run my system back a few weeks, but Timeshift ended up in an error state.

No huge surprise in retrospect, since I had deleted Timeshift’s cache!


#12

The more I read about Timeshift the more I wonder why so many people use it. It seems like a terrible backup solution.


#13

I’m very curious what backup solution you like better.
I didn’t mean to imply that Timeshift was terrible - just that there’s an outstanding bug. Since I found a workaround, I’m still using it. In the past, I’ve found it’s backup a life saver. That said, I’m always up for checking out a new backup product. (As a former IT professional, I’m a firm believer in backups!)
Best, Jim


#14

#15

Interesting! Thanks! I’ll check out Borg.
I’ve been using the Linux Backup Tool for external data backups and Timeshift just for automatic ‘system’ backups. About once a week I create a new Timeshift backup and delete the old ones. I do a data backup about once a month or when I think of it - most of my data isn’t stuff I can’t live without.
I remember trying Clonezilla awhile back and having problems with it - don’t remember what but it apparently wasn’t easy enough for my simple mind. All I want is to hit a button and get a backup to an external drive.


#16

It depends.

It isn’t perfect, but it does have many useful features. The nice clean GUI (as you point out in another thread!) is especially important to new users. As is automation.

I like the fact that I can perform a total restore in less than 5 minutes. And since I have loads of space on my sda I don’t have to worry about the space the backups use.

I also like the the concept: Timeshift images and compresses that image of your partition. Then all subsequent backups are merely a lists of changes from that “iconic” backup.

I still use “redo” to make by-yearly images, but I seldom use them.

I think a lot of the issues with Time shift have to do with the fact that it’s still quite new, that people have been converting to smaller faster SSDs, and finally that it is the nature of forums to dwell on problems.

I don’t think this is because people are negative by nature, but that problems are far more interesting than their solutions. :wink:


#17

I agree with you on everything you’ve said. I have never had a problem with it at any time and the restore feature is great. Unless I made a great change I have not done a back up, which I would do on a external drive any way, since I started using it. I have never ran out of space because if the disk is getting full I just delete earlier ones and just keep the most recent


#18

this is one of my favorite parts (as well as the quick snapshots). i timed a restore (after a weird update issue) the other day and even with my hdd it was less than 5 minutes door to door from clicking on restore to having my desktop back up and running :slight_smile:


#19

It takes my redo CD longer than that just to boot!


#20

Now that Mint has incorporated it into 19.X it should attract more funding and any persisting problems should evaporate pretty fast. Whatever those problems might be. So far–other than rather stupidly deleting Timeshift’s cache–I haven’t had any!