Trying to boot laptop: error message "wmi: failed to parse WDG method"

Hi all, :wave:

I have a problem with my old laptop and I´m afraid there´s not much that can be done about it. :frowning_face:

Despite that I´d like to ask around as I really want to know what it´s about.

The laptop is a Medion Akoya E6222 and it´s about ten years old.

It came with WIN 7 installed at the time. Later I set up dual boot: WIN 7 and Lubuntu.

As both OS´es have reached EOL (WIN 7 a long time ago) I now wanted to abandon dual boot and set up Linux Lite 6.4 as the only OS. I downloaded the respective ISO and put it on my ventoy stick.

I haven´t used the laptop for a long time and wanted to go about installing LL now.

Yet I ran into massive problems :neutral_face: :

LL from the ISO wouldn´t boot as a live system.
Trying to boot, it drew some weird output on the black screen:

[         4.025879]  wmi: failed to parse WDG method

and so on.

So it´s this
wmi: failed to parse WDG method
message I´d like to ask about. What might it point to :question:


I also tried to boot some other live systems on my ventoy stick, like Linux Mint, Bodhi Linux etc.
It was pretty much the same with them. :thinking:
Neither could I log into my already installed Lubuntu. It wouldn´t accept all of my keyboard input at the login screen.

Does anyone have a clue about what´s going on :question:

Thanks for your help in advance and many greetings
Rosika :slightly_smiling_face:

Try to boot with a CD or DVD, a W7 CD, if you have one, would be idea, just to see if the laptop will boot.


When you start the computer do you get the option of going into the bios (f2, F10, ESC, or del) and once inside that can you see the system clock date and time is that ok … Thinking CMOS battery.
Do you have another usb to put a mountable system on the try
Still in bios can you see the boot order and does it offer the access to usb or dvd to mount on start up.
Given the age of the machine it should be 64 bit… But you could try a 32 bit Linux system.
Just ideas


Most likely the kernel of Lite is too new for the hardware.
Can you boot anything? eg Clonezilla, SystemRescueCD, Knoppix, Gparted. They are all fairly rugged and will boot in just about any machine, as long as the architecture is right.

Do you know if laptop is 32 bit or 64 bit… trying to boot a 64 bit Lite in a 32 bit laptop might do this.

And, as said, is the BIOS working, can you get into it?
And as @4dandl4 said, try a different medium to boot from. I have a portable DVD drive that plugs into usb… do you have that? Is handy for cases like this

I dont think your laptop is broken. Relax and try and debug this.


Hi again, :wave:

thanks a lot to all of you for your replies. :heart:

@4dandl4 :

I´d have to look around to see if I have any bootable CD or DVD anywhere.
But as far as boot per se is concerned:

I at least I arrived at the login screen. I guess the boot process must have been finished at the time… :thinking: :question:

But that´s all I could achieve. I was able to type in the first 5 letters of my password, the others wouldn´t be accepted any more. :

Yes, I can get into BIOS without any difficulty. I tried that yesterday. I didn´t have a look at the time, but I will do that. Thanks for the hint.

I´ll have to look for one. But I don´t think the ventoy stick is to blame as I also have difficulties getting my already installed Lubuntu (residing on the internal HDD) to work. :neutral_face:

Yes, but I don´t have to go into BIOS to do that.
When powering up the machine I just punch in “F10” and I arrive at a dedicated boot menu. Here I can select the boot medium, in this case the ventoy stick.

Yes, that´s correct. It´s a 64 bit machine.

@nevj :

O.K. But in this case the sheer attempt of trying to boot Linux Lite 6.4 must have changed something (probably in BIOS :question: ).
Is that possible at all :question:

Because: A few days ago I could perfectly boot into the installed Lubuntu OS and it ran without difficulty.

Then yesterday I didn´t boot into Lubuntu first but immediately tried booting Linux Lite live from the ventoy stick.

I could boot rescatux, if I remember correctly. I´d have to try other OSes. But BodhiLinux (32 bit), Lubuntu live etc. produced the same

error message…
… and this weird 1[[D^[[D^[[D^[[D characters seemingly filling all empty spaces on the display.

Yes, no problem with that.

I have to take a look. Thanks for the suggestion.

Thanks for the heads-up.


I was doing some more research (admittedly also with the help of ChatGPT) and
found this out:

The message “wmi: failed to parse WDG method” that you’re seeing during the boot process suggests a problem related to the WMI (Windows Management Instrumentation) subsystem on your laptop.
WMI is a Microsoft technology that provides information about the hardware and software configuration of a system.

In this case, it seems that the Linux kernel is encountering an issue while parsing a specific WMI method related to the “WDG” (Windows Debugging) functionality.
This error message usually indicates a compatibility issue between the Linux kernel and the laptop’s firmware or ACPI (Advanced Configuration and Power Interface) tables.

I was wondering:

Is it possible that ACPI can have an effect of display performance :question:
I noticed a distinct flickering of the display when trying to boot from the ventoy stick.

The display itself should be o.k. as there is no flickering at all when displaying the BIOS or trying to boot the installed Lubuntu or even when I ran MEMTEST yesterday. :thinking:

Thanks a lot to all of you.

Many greetings from Rosika :slightly_smiling_face:

I doubt it, programs cant write to the BIOS, as far as I know.

Programs can write to the disk. is it EFI boot? It may have written to EFI partition. It would be unlikely to write on the MBR if it is legacy boot. Does it have secure boot?

You get to the login screen., That means linux is running.
You cant type the login. That means keyboard and/or graphics drivers not performing, or the login daemon not running.
When in the bios you can type stuff… That means bios drivers (vga, etc) are OK
It worked before you tried to boot the live Lite usb. I cant imagine a live usb doing anything to the computer… especially as it failed to boot…
Could the ventoy stick have malware? I doubt it… you have used it before.

Can you go back to Lubuntu , and try to boot it with changed kernel parameters… eg noacpi, noapic, vga, nomodeset,…
Can you boot in single user (ie recovery) mode. That should avoid the login screen

Is there any way to do a reset on that machine. On a desktop you take the cmos battery out and that lets the bios forget any settings. I dont know what you do on a netbook?

Its an interesting challenge.


1 Like

Thanks, Neville, for your evaluation of the situation. :heart:

That´s what I was thinking as well.
I was just wondering about that as I could boot into Lubuntu a few days before.

Curious, though, that I could type the first 5 charcters of the password. These were letters. When I wanted to proceed with digits I ran into difficulties. :thinking:

Yes, that´s true.

I think I can eliminate this scenario as a possibility.
I used the very stick to install Linux Lite on my desktop computer in January.

I´d like to try that, Neville. But I need your help with that.

noacpi, noapic, vga, nomodeset,…

It´s a long time since I dealt with such things… and only in theory.
How do I go about it?

I´ll also look at the other options you mentioned.

Thanks a lot and cheers from Rosika :slightly_smiling_face:

You go to the grub menu, arrow down to the thing you want to boot, type ‘E’
and you get the grub configuration file
then you can arrow down to the line that starts with ‘linux’
and you will see the boot parameters on that line… just add in the ones you want
Then tell it to boot, and it will boot with your edited linux line
The change is not permanent… your grub config on the disk stays as was.

To boot in single user mode use grub menu and just select advanced options and then recovery mode.

. When I wanted to proceed with digits I ran into difficulties

Check … caps lock, numeric keypad status, keyboard settings in bios

I bet you can crack this

1 Like

Thanks Neville. I´ll try that.

As it´s still a dualboot setup at the moment I tried logging into WIN 7. And it worked.
One thing though: The touchpad double-click didn´t work.

Right and left buttons work and I can move the mouse with the touchpad but no double-click.
Might that be a hint to something :question:

I´ll keep you posted.
Thanks again and cheers

Rosika :slightly_smiling_face:

Uh, uh, bad news it seems. :slightly_frowning_face:

I couldn´t get along in the BIOS.

  • the BIOS shows the wrong date indeed: Thu/11/16/2023

  • also in BIOS: some keys won´t work: arrow left doesn´t work, the ather three arrow keys do
    plus: the number 1 key doesn´t work, the other number key do.

All in all: It doesn´t look good.

Many greetings from Rosika :slightly_smiling_face:

If the time date is wrong in the bios then it’s a new cmos battery needed they are only around 5 euros and easy to do so nothing lost by changing anyway. But may not solve the problem.
The standard is a cr2023 battery, but (too many bits) on some the cmos is soldered direct to the mother board in the form of a capacitor on others it’s on a fly lead and you have to buy the full unit at around 15 euros.
Search change cmos on internet for your machine to discover.

1 Like

Another option on your boot usb will the computer start up and show a display to either work with or install. This will tell if the screen is faulty.

I have seen this before - somewhere 10 or so years ago - had to disable ACPI to get Linux to run… No idea of the details - but that rings a bell… I think in grub maybe you have to add ACPI=disabled (or something like that - don’t quote me YMMV [your mileage may vary]).

edit : update - probably more like 15 years ago… time’s getting away from me…

1 Like

I wonder if the cmos battery is failing?
That must be an American date?
Are you running on battery or plugged in? It may be a power supply issue

Is that a typo? Do you mean cr2032?

Yes sorry my error cr2032 is correct
Thanks for pointing out my error
I don’t think you can get a spell checker for numbers

1 Like

Hi, @daniel.m.tripp @nevj :wave: :

thanks so much for all of your replies. You´re really great. :heart:

That was my first thought as well.
When booting into WIN 7 yesterday I managed to change time and date manually and - curioulsly enough - up till now the laptop has kept the changes. :slightly_smiling_face:

Thanks for hint anyway. I think I´ll get hold of a CR2032 anyway. I believe they are 3 volts.

Thanks also for the additional info, Paul.

I´m pretty sure (and very much hope) the screen isn´t faulty (see below).

@daniel.m.tripp :

That would be the noacpi parameter then, which Neville referred to yesterday, I guess.
I´ll keep that in mind.
Thanks a lot.

@nevj :

I´m running the laptop in a plugged-in state.

Yet I´m pretty sure the power supply is alright.
Also: the battery is completely charged.


What I have done yesterday after doing some additional pondering:

The laptop has got 4 usb ports, 2 of them usb 3.0 and the other two usb 2.0.
I tried the usb 3.0 ones and also one of the usb 2.0 ones. Every time the same result.

Out of curiosity I finally tried the last one (usb 2.0) and suddenly it seemed to work :astonished: .

From the ventoy stick I could boot into Linux Lite 6.4 live with no screen flickering. :exclamation: :exclamation:

Plus: Every one of the number keys worked, even “1”, which I couldn´t get to work before.

So LL as a live system booted well. But what about the installed Lubuntu?

For this I disconnected the ventoy stick and tried again.

Now I could log into Lubuntu as well, as even here all number keys worked. :wink:

Right now I´m in the middle of installing Linux Lite 6.4.
I´ll keep you posted.

In the meantime: Thanks so much for your kind help, all of you. :heart:

Many greetings
Rosika :slightly_smiling_face:

1 Like

[quote=“Rosika Schreck, post:17, topic:10550, username:Rosika”]
I finally tried the last one (usb 2.0) and suddenly it seemed to work

Hi Rosika
Congratilations, but be prepared… this issue may return to bite you.
Thinking about overheating, and does it need a clean?
These symptoms are indicating poor electrical connections somewhere, probably soldered joints.

1 Like

Nev’s got a point there - I’d suggest reseating any RAM modules too…


Hi again, :wave:

thanks so much for your feedback. :heart:

Sorry I couldn´t reply earlier as I wasn´t online yesterday.

@nevj :

Thanks, Neville.

O.K. I hope to be prepared.
I don´t think it needs a clean. Haven´t used it in a long time, and even before that: hardly ever.
But it´s good to keep this point in mind. :+1:

Oh, dear. That doesn´t sound good.
I have to watch it closely then. At any rate: I won´t be able to miss any funny things, will I?

@daniel.m.tripp :

Thanks, Dan.

Well, never in my life have I opened a laptop before. I wonder whether I would be able to accomplish things like that… :thinking:

At any rate: I always wanted to get hold of one of thoese antistatic wrist-bands. Just in case…
I´ll have to tackle this one then.


Just a certainly very stupid question. I aplologize in advance for asking it:

Would the laptop (in its present state) be safe to use at all :question:

I mean: from the security point of view - software-wise.
Suppose there were any poor electrical connections somewhere. That wouldn´t affect the software running on it, would it? Like the OS running any un-initiated commands all by itself :question:

I warned you: this is a very stupid question. :blush:

Thanks a lot to all of you.

Many greetings from Rosika :slightly_smiling_face: