Ubuntu 22.04 upgrade-in-place crash

On an old laptop I installed 22.04 after wiping the disk. That install went smoothly.

This morning I tried doing an upgrade-in-place on a Lenovo X1-Carbon 7th gen. That did not go smoothly. After the installer determined the changes needed, downloaded 2306 packages, the screen went blank and the computer went into suspend mode. (It was plugged into power throughout.) I could not get it to stay on. I did see, briefly, a pop-up saying that a problem had been encountered and would I like to send it to the developers. However the computer wouldn’t stay on long enough, only a second or two before it re-suspends, for me to click the “send” box. I did a forced shutdown and the computer rebooted to 20.04 as normal, no harm done.

Has anyone seen anything similar to this? Suggestions to avoid the problem?

Thanks.

Hi Don, :wave:

Sorry to hear of your problems.

That´s what I always was a bit afraid of as well.
Never tried an in-place-upgrade so far. :expressionless:

To avoid such a scenario I always do a fresh-/clean-install, so basically a nuke-and-pave-approach.

With 3 partitions (home, root and data-partition) I just keep my data-partition (not formatting) and install a fresh root and home.

Actually there´s just a lively discussion going on about how it can be done here: General question regarding support period of distros (Ubuntu and derivatives) .

All the best and many greetings.
Rosika :slightly_smiling_face:

I’ve done 18.04 to 20.04 (x86_64) numerous times and NEVER run across any trouble… and I did once try a 20.04 (which had started life as 18.04) to 21.04, and didn’t hit issues there either…

Also - one of my Pi4B (8 GB) started life as a Ubuntu 20.04 arm64, and upgraded “in place” to 22.04 - hit a few issues but was able to resolve them (don’t remember the details)… It pretty much crashed the Pi, but managed to get past that - sorry don’t remember details, but I’d imagine arm64 on a pi4 would somewhat different to your case…

Note also : I’d nearly always recommend install from scratch - like @Rosika suggests…

:smiley: - well put :smiley: … I never have “volatile” data stored on my HDD or in $HOME (other than that sync’d across 5-6 computers using resilio sync) so “nuking” as @Rosika so “elegantly” put it, my $HOME and HDD is never that painful… The most painful part is re-installing all my Steam Library from the cloud (and I’m stuck with shitty copper broadband for the time being) Steam offer a “Backup Solution” but it’s pretty flaky, and clunky… i.e. doesn’t always backup everything, and I’ve found items that won’t restore later on…

1 Like

In the end a clean re-install was necessary. (Don’t ask.)

Why not explain?

I made a silly mistake in manually partitioning the disk which resulted in me having to do a couple of hours of tedious re-installs.

If you could explain the main aspect of your mistake, you could perhaps help other people refrain from repeating that mistake.

1 Like

Hi Dan, :wave:

Thanks for the compliment, Dan :heart:.

To tell the truth (and if I remember correctly) if was Larry Bushey (who once discussed together with his co-host some advantages and disadvantages of various “upgrade” methods in one of his podcasts) who used this term.
Hadn´t heard it before either. This term somehow got stuck in my brain. :blush:

BTW:
“Going Linux” podcast shownotes can be found here: Going Linux · Shownotes - in case anyone is interested.

Many greetings from Rosika :slightly_smiling_face: