Ubuntu Budgie - solved my problem

I won’t go through it again, but the short version is that I have been having a blast playing with Linux distros, By the standards of this forum, I am a novice. A user. I like to work through a DTE as much as possible and I like my stuff to work.

Which brings me to a problem I had. Through MULTIPLE runs and installs of several distros, a Dell Inspiron with a Gen 8 i7 and 12 GB RAM was performing perfectly horribly. Load times were running in the 5 minute range. Once it got up and going, it was fine, but these load issues had me convinced it was an HD issue, probably with partitions, maybe with encrypted partitions. I was running Zorin when the problem first got insufferable. I switched to a clean install of Pop! OS and it didn’t do any better. I tried several reinstalls, some troubleshooting in Terminal to rid myself of some partitions and other tricks I read online. Nothing worked. And it could have been a different issue altogether.

I have been impressed with Solus Budgie (and not impressed with Ubuntu in general use), but a lot of online help suggested Ubuntu. I chose the Budgie flavor and got to work loading it on a thumb drive. I did a clean install using the ZFS file system and the computer runs beautifully (EDIT: WITHOUT ENCRYPTION).

So for all my running down of Ubuntu, it was the magic sauce that got this one back up to speed. I still like other distros better, but I must say, it works when others didn’t.

2 Likes

I recently tried out Ubuntu 20.04 on my Thinkpad E495 (AMD) - using ZFS encryption - BIG MISTAKE! Ended up formatting - reinstalling Ubu 20.04 with just LUKS and problem was solved (note - I’ve done a series of distro-hopping ~recently, and it now has Fedora 36, but I haven’t powered it up for ages - I’m using its power brick (USB C) to power my work’s HP laptop (win10) which I will be tacking back to work tomorrow and leaving it there - it always cheeses me off when IT staff get the same locked down bullshit as the beancounters and project managers!

Don’t get me wrong - I’m a BIG fan of ZFS - my favourite filesystem, but I don’t think this hardware / software combo was up to the task - it would slow to a crawl, and I could see “z” processes related to ZFS writes and reads eating CPU - I use ZFS (not encrypted) on my FreeNAS (now TrueNAS) - and that’s only a dual core Turion (HP N40L microserver) - but it does have 16 GB of ECC.

1 Like

I did NOT encrypt. I had trouble with encryption using Pop OS and I suspect that’s what led to my Zorin issue on this same unit.

As far as I know, encryption is only for off-site backups. Meaning, once decrypted, performance should be pretty much the same, as if no encryption were present.
Then, once you are done using the drive, you can encrypt again.

So, there’s no encryption on the fly, like on Android or something.

At least, that’s what I know. Maybe there’s something I’m missing.

I am no expert. But when I encrypted on the Pop! OS install, I got an error and then my drive wouldn’t boot. I had to reinstall. I did a clean install and encrypted again… same result. I downloaded Pop again and tried a third time with encryption and it was no different. So on my next try, I didn’t use encryption. I had no problems with the install, but the device felt slow. I didn’t think about it at first. I thought it was booting slow into setup, my learning curve with a new system, etc. But subsequent reboots were bad while my other machines (with inferior processors was far zippier). I ended up with Zorin which seemed decent, but I couldn’t get past how bad the load times were.

Bottom line, I don’t know. Likely never will. I lack the expertise to troubleshoot it and determine the issue. But Ubuntu has it running a lot faster. I don’t love Ubuntu, so I may go back to Zorin and see if it works RIGHT this time. If not, I can make Ubuntu work fine. The suck of it is that this i7 SHOULD be my fastest computer (the closest thing I have to it would be a Gen 11 i3 with 4GB of memory). But that hasn’t been the case since that Pop install. So we shall see. But I gotta give kudos to Ubuntu. It’s “the standard” and there are times that it’s apparent.

1 Like

Hi @fishyaker ,
I am not sure what your sequence of events is, but I had this sort of trouble when I accidentally installed a ZFS filesystem on a disk, then wiped it with Gparted and went back to a normal partitioning with ext4 filesystems.
So question, did you use ZFS , then change back to some other filesystem?

The problem is ZFS leaves trace of itself right at the beginning of the disk, in the MBR region, and these traces interfere with grub booting.
There was a post on the issue called .
Wipe ZFS signatures from a disk
If you think it is relevant to your issue, you should read it.

You can check if there are any ZFS residues by doing

# wipefs /dev/sda

Be careful using wipefs… it is as dangerous as it sounds. The above is safe, it is just a query.

I hope this is not your issue, because it is a beast to get rid of, but there is a method… see the post

Regards
Neville

Warnings about wiping commands, should probably be shown before the command and ideally be marked bold or something.

1 Like

Agree. That particular use is safe… it just lists stuff.

I see. That wasn’t clear. I assumed “the above” was referring to something else.

1 Like