Unable to find Boot from USB option even after following the given instructions

I have disabled secure boot, legacy boot, and fast boot options. Used Rufus latest version to create an image of Ubuntu 16.04 in USB. When I go to boot options when restarting, boot from USB option is not coming. Can anyone please help me? I’ve wasted a whole day on this.

Welcome @Praveen_Samudrala to It’s Foss Community. I’m sure someone on this forum will be able to help you with this problem. The only thing that comes to mind is your BIOS setting. In (my) BIOS, I can select the devices the PC will boot from and what order to look for the boot file. So on my PC I have USB first, HDD second, and DVD third.
If this does not help, you may want to list what is your PC model.

Hi, I have tried changing the boot order as well putting USB at first, but didn’t work, still not able to find Boot from USB option.
My PC : HP Pavilion G6 2210

The next 3 things that I would try are 1) try a different USB port on the PC and 2) re-create the bootable USB flash drive and 3) try a different USB flash drive to make the boot drive from.

Hi, I’ve tried the first 2 things, will try with different usb now.
Also, I’ve made few observations, may be that can help anyone giving me suggestions.
First is, my HDD has partition scheme as GPT, where the partition scheme Rufus is using to create image in USB is MBR. I read in a post that changing schema could work, but was not getting the dropdown value as GPT in Rufus for partition scheme. So that was dead end.
Second is, I’m getting 2 boot options, ‘OS boot manager’ which is taking directly to Windows 10, second is ‘Boot from UEFI file…’ which is opening a file explorer sort of thing where I can see my USB stick and folders inside it. I didn’t know what to do with that, so exited. That confirms that PC is detecting USB, but not giving option to boot from it.

1 Like

Hi @Praveen_Samudrala, I wish another member with more experience would jump in with a suggestion for I am still learning about GPT and UEFI. As far as I know GPT does not automatically give you UEFI. My next suggestion would for you to go into BIOS and set your PC to boot from UEFI.

On my laptop once I set to boot from UEFI, I could no longer boot from MBR even tho there was a option to boot from Legacy, which I took to mean MBR. If I wanted to boot from MBR again, I had to go back into BIOS and remove the UEFI.

So see, I might not fully understand this, but found a procedure that worked for me. It’s like the PC only wants to boot MBR or UEFI, but not both w/o changing BIOS.

  1. Enter the UEFI and set boot to UEFI only. No Legacy/BIOS or CSM enabled.
  2. Write the ISO image in DD mode and GPT/UEFI only mode to USB with Rufus.
  3. Try again.

See Q5:

1 Like

Thanks for all of your support. I used an older verson of Rufus to flash the USB which was giving an option to create with GPT partition. Then I was able to see USB option in Boot options. The partition schema of HDD and USB should be the same is what I learned :smile: