Unable to run Balena Etcher on Ubuntu 22.04

I amrying to install Balena Etcher on Ubuntu 22.04, following their official instructions for repository setup.
Near the end of the installation it spits an error: chmod:

cannot access ‘/opt/balena-etcher-electron/chrome-sandbox’: No such file or directory

It seems the path is incorrect, the package installes to /opt/balenaEtcher, but the postinst script reffers to /opt/balena-etcher-electron…

Downloading the AppImage from the official site spits out another error:


(balena-etcher-electron.bin:49252): dconf-WARNING **: 17:58:54.507: unable to open file ‘/etc/dconf/db/local’: /etc/dconf/db/local: invalid gvdb header; expect degraded performance
[Axios v1.7.9] Transitional option ‘clarifyTimeoutError’ has been deprecated since v1.0.0 and will be removed in the near future
[Axios v1.7.9] Transitional option ‘forcedJSONParsing’ has been deprecated since v1.0.0 and will be removed in the near future
[Axios v1.7.9] Transitional option ‘silentJSONParsing’ has been deprecated since v1.0.0 and will be removed in the near future
[49252:0524/175855.122467:FATAL:gpu_data_manager_impl_private.cc(415)] GPU process isn’t usable. Goodbye.

Any ideas?


Hello Amichai welcome to the forum. I have just installed April 22 deb file version of Balena Etcher into Ubuntu 22.04 Download the file that says 1.7.9_amd64_deb, from the blue link above. Also open up a terminal and install gdebi sudo apt install gdebi open deb file with gdebi and wait for it to install, it will say is already installed and give you the choice to remove or reinstall. I done it in VirtualBox, also before logging into your Ubuntu 22.04 click on your name on the login screen you should see a cog come up, bottom right of the screen, click on it and choose x11 display. A lot of the time that things won’t work is because of Wayland, as apps and things are still transitioning over to Wayland display support.

1 Like

I am a seasoned Linux user (since 1999), so I don’t need GDebi to fix dependecies. I’ do everything on the command line, thank you, thogh.

This is what I’ve done:

apt purge balena-etcher-electron

I’ve downloaded the file from the link (it’s name is different, BTW), and installed it as root:

sudo -i
apt install ./balena-etcher-electron_1.7.9_amd64.deb

After a nomal installation process I got the following error, and the app won’t open using the launcher:

N: Download is performed unsandboxed as root as file ‘/home/a.rotman/Downloads/balena-etcher-electron_1.7.9_amd64.deb’ couldn’t be accessed by user ‘_apt’. - pkgAcquire::Run (13: Permission denied)

Trying to run it from the CLI. I got the exact same errors mentiond in my OP.


If you downloaded a .deb file outside the package system, the usual practice is to install it with dpkg -i rather than with apt.

I am not sure why dpkg is used, or whether it makes any difference.
Its just what I have always seen people do.

1 Like

Yiu are correct. That is, historically, what people do. Technically, both front ends talk to the same back-end, in a different way. using the APT command is the same, because it essencially downloads a .deb package from the respective repository and installes it. AFAIK, a .deb file included the actual pre-compiled binaries. and a podtinst script to tell it wher everything goes after putting the binaries in their respective location.

The error I mentioned is actually because I used apt instead of using dpkg.

I understand the reason it doesn’t work is because the electron bundled in the latest (1.7.9) Etcher is old and incompatible with modern versions of Linux, something the guys at Nalena are ignoring the problem and did not fix the .deb file…

1 Like

We are hearing every day about this sort of issue… packages getting out of sync with other parts of the system. It is becoming like an epidemic.
That suggests that interactions are becoming too complex to manage.
People are proposing things like flatpak as a solution… that is an aweful ‘solution’

Anyhow, I am glad you at least know where your problem arises

My personal file of ISOs and related files contains the file: balena-etcher-electron-1.5.121-linux-x64.zip. Don’t recall where I found it. It unzips to give me this file: balenaEtcher-1.5.121-x64.AppImage. Checking the files permissions, I have the box for executable checked.

When I open the file, I get a dialog box asking for the file (presents a file manager so I can identify the ISO). The second item asks for the target drive (presents the file manager so I can specify the USB stick where I want the ISO). The third item is Flash! Clicking flash brings up an authorization dialog box, which I assume is the GUI equivalent of a sudo password.

When all of that is processed, the process bar proceeds pretty quickly to complbalena-etcher-electron-1.5.121-linux-x64.zipetion, validates itself, and asks if I want to flash another.

Balena Etcher has always worked for me when I quit trying to install it. Just unzip the download and execute the AppImage file, checking the permissions tab first.

Installing would never work for me, but just executing has always worked.

Just curious why you’re eschewing the ancient, tried, and true “dd” command…

That’s all I use for writing ISOs to thumb drives, or img files to SD-cards for ARM SBC’s…

I think the last time I tried a GUI tool, it might have been the RPi imager gui for Linux / x86_64…

I also remember something lke Balena Etcher (maybe it was even Balena) it was an AppImage or something, and it just worked???

Can’t even remember why I resorted to a GUI solution to a “dd” type answer…


I feel the same. Etcher is a bit of an overkill for doing what dd does. Maybe it does extra things?


It does make life easier. dd has use cases where it’s not so hard to use, but it also has use cases where you need to exactly know what you are doing or you will break what you want to do.

A GUI tool, like Etcher, makes life easier by taking care of stuff and you just have to select source and target file, that’s it. You also don’t need to open a terminal window for that.

It might also be the case that it uses additional advanced writing options behind the scenes, to further improve writing efficiency or the resulting artifact’s quality.


Etcher includes a warning that the target USB stick will be emptied and formatted during the process. I’m going to have to look up dd and try it.

Bill, there is just one thing to be very careful of with dd
make sure you get the of= outputdevice parameter correct
double check
if it is wrong it will silently write all over the wrong disk
you know what that means

1 Like

That’s, for example, another thing a GUI application like Etcher does better. It’s much easier to distinguish the different storage media with icons and visually depicted IDs rather than through pure obscured text form inside a terminal.

maybe I’ll stick with Etcher

I am going to be stubborn and assert that I would rather know what I am doing than live behind a GUI screen which filters everything for me.
In some cases I do prefer a GUI, but only the ‘talkative design’ gui’s that
let me know exactly what will happen if I press the button.

I did not mean to scare you off. Just be cautious and know the common traps.

I understand you and I feel similar a lot of times. However, 99% of people don’t care and I don’t think a doctor, pilot or car mechanic should be forced to look behind the GUI. There should be an easy GUI for them available, if they want to achieve something using the computer. They shouldn’t be forced to look behind it and understand it.
The same way I don’t expect the car mechanic to tell me how I can repair some complicated motor failure myself. I want him to fix it; that’s what I pay him for.

That’s unrealistic. Even if you tell the car mechanic exactly what happens, he won’t understand, because it will all sound like tech jargon, he never ever has heard of in his entire life, before. So, why bother? And he doesn’t even want to know, anyway. And should not be forced to.

You misread me.
When you hover over a button it should pop up a good description of what it will do.

What is a “good description”?

One that I understand, and rhe average person would understand.
I know that is subjective.