Windows 10 doesn't install due to no media driver found

I am currently using Ubuntu 20.04. So, I want to dual boot windows 10 with it.
I downloaded windows iso file from a site(pirated). After creating a bootable usb with it (although Balena-etcher gave warning about no partition table found in iso file) ,I booted from this usb. However when I click “Install now” button (the one on the first blue screen after choosing language etc), it gives me error that ‘A media driver your computer needs is missing’.

However, the iso file works well on virtual box. I have installed it on qemu and I faced no problems there.
I tried to change the usb port also, but it didn’t work.
After that I downloaded Intel Rapid Storage drivers into a hard-drive partition. I couldn’t extract them to the installer usb because it told me that this is a read-only filesystem. So I extracted them on the hard drive and tris to install them from the windows installer. It showed the drivers successfully however doesn’t install them.
I am using a Dell Vostro 3580 laptop.

Etcher is not purposed for creating Windows boot media. If you try it just fails. Try a different tool and you will succeed

Downloading from a pirate site can be a problem in itself

Go direct to Microsoft to get a real one

You may have to change language on above as I am in France

Then try a media creation tool such as pen drive to create a working version

Actually, privately distributed Windows is almost always way more reliable and better than Windows distributed by Microsoft. Please don’t spread corporate propaganda.

I know you said, that the image seems to work in VirtualBox, however still follow the guide on how to properly verify an installation medium before usage, as described here in Q5:

1 Like

It would be illegal and unethical to recommend downloading any system or software from any un known source. You are inviting followup from the supplier and risking the future of any installation.
At least with the suppliers site you should be getting a valid original copy with less chance of virus or other issues.
Think mint or Ubuntu where do you go to get them… originall supplier not a pirate copy.
Just for the record I would not recommend installation of any Microsoft product as I prefer Linux, but when someone asks for help on a topic it is correct to use the suppliers site.
I spend my working life removing Windows due to virus issues to be replaced by Linux.

@Akito Thanks. Actually, now I used Woeusb to create the bootable USB. The sha512 hash outputs matched. And I was able to install windows.
Thanks all for helping me :smile:

1 Like

I found the official download from Microsoft worked fine when I updated Windows 7, but, it’s my understanding it won’t work unless you install windows first then install whatever Linux you want.
Saying that, win 10 had a failed update in October 2017 so I haven’t used it since and use Mint exclusively. I keep a small hard drive (160Gb) with Vista just in case I need microsoft for anything (plus a different old drive with Win XP and Ubuntu 12.04)

I am running W10 v2004 and running Mint LMDE in a VirtualBox VM, everything runs really well.

Your best option is to download W10-1909 from the MS site then use a tool like MSMG to remove from it want you don’t want, like the privacy apps, homegroup, or the apps store in general. Add the drivers for your cards, motherboard, even the CPU if its an intel. Then create your own iso & install that. Works everytime. w10 2004 is buggy as with every other release, so use 1909.


Using 2004 right now and this is one of the best versions I ever used.

2004 gives you WSL2.

1 Like

I have no problem with W10 v2004 either!!!