Help installing Ventoy

Hello Everyone-
I am intrigued with a multiboot disk tool Called Ventoy. It’s a simple install I’m sure for a veteran Linux person but being a newbie that is not the case. I am constantly trying new distros and moving slowly
up the food chain, I am having trouble installing ventoy. Could someone please help me out, preferrably with copy/paste text. This is the level of my linux ability at this point.
https://www.ventoy.net/en/index.html
TIA

It would be helpful if you could elaborate on your issue.

You should look at the FAQ and if you don’t find an answer right away there, you should fill out the included template.

my issue is that I am not proficient with terminal use , commands etc. I can copy/paste but sadly that is the extent of my experience at this point.
Thank You

Well, we still don’t know what your actual issue is. What do you want to do?

I wan to install the Ventoy program to a usb drive. I tried to follow a guy on youtube but he was either using a different distro or an older version of ventoy. I got errors in the terminal “command not found” or something like that. Thought I’d humble myself and ask for help.

Can you please describe exactly what you are doing? Please use the template from this post:

Please describe your issue as precisely as possible, step by step or else we won’t be able to help you out.

Well, my apologies if I am not posting correctly. I am new to this. I am new to linux.

I found this program, Ventoy, which is a multi boot disk which can allow me to keep one disk with several distros. I am trying different ones all the time.

I do the extracting of the tarball with no problem. then in Terminal cd Downloads , and then sh to install. My issues come in with the commands of getting the thing to install on the usb drive. I’ve tried what I know but nothing works… Obviously doing something wrong.

I understand this is elementary for seasoned linux users, but that does not describe me. I am a newbee. If you can help or even point me to where I can learn these commands I would very much appreciate it.

Thank You…

Ventoy is just another way to create a bootable USB drive. If you are using Linux, then the same thing can be accomplished with an ISO and the dd command. If you are using Windows, and are Distro hopping, then use VirtualBox, to try out the Linux distro, you can even install VirtualBox on Linux, and do the same thing. If you are the Newbie, you say, then you really have no idea as to what you are asking.

1 Like

this is exactly why I was reluctant to ask you people anything.

Look.

  1. You come and ask for help.
  2. We want to help you.
  3. We ask you for information so we can help you as best as we can.
  4. You don’t provide information.
  5. Instead, you are expressing yourself in a derogatory manner toward us.

Please understand – we cannot look into your head. If you need help, please help us help you.

1 Like

Welcome to It’s Foss Community @meltexas. Never hear of Ventoy before and did a little reading on it and it sounds interesting. So I learn something today. Thanks.

3 Likes

Hi @meltexas,
I’m noob in linux too.
I’ve just installed Ventoy to test it and followed these steps (I use Linux Mint):

NOTE: Ventoy has 3 options:

  • -i (install ventoy to usd pen)
  • -I (caps i - force install ventoy to usb pen)
  • -u (update ventoy in usb pen)

1 - connect your USB pen to you PC
2 - run this command to know the name of the USB device:

  • ls -l /dev/disk/by-id/usb*

in my case it is /dev/sdf:

4 - download Ventoy
5 - Decompress Ventoy
6 - open a terminal window and go to the directory where Ventoy is decompressed
5 - run the command to install Ventoy:

  • sudo sh Ventoy2Disk.sh -i /dev/your_USB_device name
    in my case the command is: sudo sh Ventoy2Disk.sh -i /dev/sdf

If you follow these steps, let me know if it worked out for you

FOSS - For Outstanding Super Specialists … who forgot they were noobs once aswell

2 Likes

Thank you. That’s exactly what I was asking for. Most of the good people on here operate on a much higher level than us newbies so It’s hard to communicate.We are like two yr olds. I appreciate it. Linux Mint Rocks. I was actually looking for someone on Craigslist I could pay to do this… I was a couple of commands short.

2 Likes

My apologies. It is a little frustrating. We newbies are like two yr olds sometimes. Communication is difficult. Tech_JA understood what I was saying maybe because he is admittedly a newbie also. One day, if I live long enough, I will also be a giant oak but for now I am as an acorn barely breaking thru the ground. (thats a metaphor)
Thank You for your help.

3 Likes

I’m curious, what are you struggling with in the installation process. I copied this from the website:
Download the installation package, like ventoy-x.x.xx-linux.tar.gz and decompress it.
Run the shell script as root sh Ventoy2Disk.sh { -i | -I | -u } /dev/XXX XXX is the USB device, for example /dev/sdb.

Is this process where you are having difficulty?

1 Like

i tried this installation ventoy to dev/sdb successfully finished (in my case pen drive sdb)
all are ok but when i copy ISO files to the usb pendrive its not booting any operating system directly opening my host operating system i changed booting priority to usb only even its not booting why its so?

Hi @Pavankalyan54,
I just tried Ventoy with the Manjaro distro and it worked.
I haven’t changed boot:
My motherboard has a menu for selecting the boot device, when I press F11 during POST.
After choosing UEFI USB PEN and pressing enter, the Ventoy menu appears and shows the list of ISOs recorded on the USB (I copied 2 ISOs to the USB PEN).

1 Like

I did the same steps till boot from UEFI USB PEN option, but it’s opened Grub terminal

Hi @Pavankalyan54,
This time I tried changing the boot order in BIOS, to run USB as the first option
After saving the settings and rebooting, I’ve got the Ventoy screen, I chose the distro Linux Mint Cinnamon (was the only one I had in Ventoy) and the distro boot (grub) appeared with all of its options

Could you try it again?



3 Likes