Install MINT with WIN10 in dual boot with UEFI

Dear friends,
I just bought an SSD card to install on my main PC with LINUX MINT, but I want to keep WIN10 already installed on another SSD card and UEFI mode
I’ve read some information on how to install dual boot, but I’m wondering if they could help me install the new SSD and OS to the best of my ability without ruining WIN10.

Is it possible, for example, to give me a step-by-step explanation of what I need to do, for example, to install in UEFI, whether I use GRUB, whether I format SSD in ext4, whether I need a SWAP partition, etc.

I don’t want to mess up on main PC

Many thanks
Jorge

1 Like

Jorge, if you have the install medium, that is on an USB or CD/DVD for Mint then just start the install as normal - the guide here is the best thing to follow -https://linuxmint-installation-guide.readthedocs.io/en/latest/ You can install Mint in UEFI mode without problems.

To install Mint alongside W10 you will need to have it installed first so that Mint will know it is there. It is very easy to do.
I have moved this to the Mint Category as it is a Mint Question okay.

1 Like

Just a FYI. This may not happen to you, but I have dual boot on a SSD. One time when Win 10 performed one of it’s update, it failed and I could not boot my system at all.
I restored my Win10 partition, but it then wiped out grub. I then had to rebuild grub. Quite a learning experience.

3 Likes

@ElectricDandySlider,
Thanks for your response
My experience with dual boot is only with the legacy BIOS, WIN XP and Debian, but it was many years ago…
I’ll read the link and tomorrow or Friday, which is my day off, I will install SSD and Mint and I’ll give the feedback in this thread

@ easyt50,
Thanks for your response.
Do you know why this happens when you update WIN10?
Is it common to happen with WIN10?

3 Likes

If you need further help there is a great thing on the It’s Foss website, just search for it and you’ll find it. Let us know how you get along.

1 Like

Not really, but I think there was (is) something not quite right with my copy of Win 10. A couple different times after updating Win 10, the update would fail and then Win 10 would try to back or restore the system back to before the update. It was one of those time when the back out fail too that left me with a PC that would not boot.

No, I don’t think so. Just be sure you have multi backups of any of your personal / important information.


It almost sounds like you want to keep Win 10 on one SSD and Linux Mint on another SSD. And not mix them on the same SSD. Is that right?

2 Likes

@easyt50,
That’s right
I currently have a 240 GB SSD with WIN 10 and an old 1GB HDD with programs and working folder and this system is working properly and I need to use it daily.
I am currently on a limited budget and have bought a cheap 240GB SSD to install Linux and keep it separate from the existing system and if for some reason I make a mistake while re-learning Linux I can format, remove etc. the SSD and the rest of the system stays operational

2 Likes

I wish @cordx was back on the board. I understand he boots about 5 different OS’s off of 2 different disks. Well, it’s good you have 2 different disks. The chances of Win 10 or Linux causing problems on the other system would seem to go way down. You might be able to have both OS’s without installing dual boot.


Just a thought, but my PC has a boot menu come up if I hit the ‘Esc’ key during powering up which let’s me select what device (USB, disk, CD-rom) to boot from. You might want to check to see if your PC has a boot menu option.

2 Likes

The best person to answer this is @Akito as he as more experience if your question is about SSD, rather than just dual booting it with Mint which I have explained to you.

You might want to start a new conversation on that in hardware, if it is not Mint specific, so that others can also so help.

1 Like

@ElectricDandySlider,
I didn’t ask any question about SSD.
I just answered to @easyt50

1 Like

Okay it was just the way it was reading. Thanks for clearing that up

1 Like

I installed Linux Mint with a USB PEN like all previous installations I have done on the laptop, but after installation, the ubuntu option did not appear in the boot options. The only way I could run Linux was by pressing F11 at boot and selecting the disk where Linux Mint is installed.

There is a detail that went unnoticed and that I leave here, if other members have the same problem:

  • If you run PEN USB in Legacy Mode Mint installation is done in legacy Mode
  • If running USB PEN in UEFI MODE MINT installation is done in UEFI

After installing Linux Mint again via PEN USB but booting in UEFI, the ubuntu option already appears in the boot options.

I installed Linux Mint with a USB PEN like all previous installations I did on the laptop, but after installation, the ubuntu option did not appear in the boot options. The only way to run Linux was to press F11 at startup and select the disk on which Linux Mint is installed.

There is a detail that went unnoticed for me and that I leave here if other members have the same problem:

  • If you run USB PEN in Legacy Mode, the Linux Mint installation will be done in Legacy Mode
  • If you run USB PEN in UEFI MODE, the Linux Mint installation will be done in UEFI MODE

USB_UEFI
In this example, we can see same USB PEN with two options: USB (legacy) or UEFI

After installed Linux Mint again with USB PEN but choosing boot UEFI, the “ubuntu” option already appears in the boot options and now I can choose in GRUB if I want to run MINT or WIN10

The command which help me find what’s wrong with my first installation was efibootmgr which returned EFI variables are not supported on this system

Now I lost WINDOWS BOOT MANAGER from boot options and I only have ubuntu and I don’t know how to have both…

1 Like

Well @Tech_JA, I am kind of new to this to, but here are my 2 suggestions.
| 1 - By pressing F11 you get the hardware boot menu. This menu should show both of your disk drives, therefore letting you choose the one with Win 10 or the one with Linux. This is not the desired way b/c you have to watching when you turn on the PC. But until Grub is built, it is a way to get to both systems.
| 2 - I do not know how to build a Grub menu, but you can forced the system to build one for you. On your Linux system, go to the Update Manager and install the kernel update. The system will then build you a grub menu. Once that is done, it not too hard to add the Win 10 boot option to it. I can look it up and post it here if you like me to.

1 Like

@easyt50,
Now I have GRUB and I can choose between Linux or WIN

If I choose Linux, it works normal: after reboot I’ve got the GRUB again to choose what OS I want.
If I choose WIN (after change with grub-customizer for previously booted entry), after reboot, the WIN starts automatically and I don’t have GRUB again. Looking in the UEFI boot options, instead ubuntu now I have Windows Boot Manager

I need to find how can I use WIN as default OS but always show GRUB at start

Probably I did something wrong but I don’t know why…

1 Like

Now I am a little confused here, so bear with me.
1 - You modify Grub and it shows both Linux and Win when you boot your system.
2 - If you select Linux, and on the next boot Linux and Win again shows on the Grub Menu and you can repeat this over and over again.
3 - If you select Win from the Grub menu, Win boots fine, but on the next PC boot, no Grub menu and the PC boots to Win.
4 - If you go back to the F11 option (hardware boot menu) and select the disk Linux is on, you again get the Grub Menu with both the Linux and Win boot option.


If all the above is correct, I would look at the boot order in BIOS and make sure the disk with Linux on it is listed as the first boot device. If this corrects the missing Grub menu, then I am sure we can change the default OS that Grub will boot.

1 Like

I’m confused too

Yes, I modified GRUB just to “remember” the last option I choose

Yes.
If I use ubuntu on UEFI boot menu, I have GRUB menu with Linux and WIN to choose what OS to boot.
If I choose Linux, after reboot, I have GRUB menu again to choose the OS to boot

Yes and the EFI boot menu changed from ubuntu to Windows Boot Manager, the PC boots with WIN and I don’t have access to linux again

No, the ubuntu option has disappeared

I have an EFI partition on WIN disc and I create other EFI partition on Linux Disc and installed the boot loader in this partition. Could this be the problem?

1 Like

I’m sorry but you are ahead of me on this issue. I use dual boot from a single disk and I don’t believe it is a EFI or UEFI disk.
**** However ****
I found this on the web “grub2 gone every time I boot Windows 10” at
https://unix.stackexchange.com/questions/241809/grub2-gone-every-time-i-boot-windows-10


I’ll put an excerpt of the answer here, but be best if you read the problem to see if it is indeed a match.
"The solution was setting the Windows boot manager entry inactive but leave it in first position of the boot order:
sudo efibootmgr --bootnum 0000 --inactive sudo efibootmgr --bootorder 0000,0002,000C,000D
(with 0002 being grub2)

2 Likes

Hi @easyt50,
Thanks a lot for the link

I found that I made a mistake on the first install (all this is new to me).
On the first install, I tried to follow @Akito and @Leslie_Satenstein tips for partitions in the Ready for the Switch thread, but last night I realized that the disk was in MBR and not in GPT as @Akito mentioned, so I formatted the disk again, but now in GPT and after installation I got the same result - After choosing WIN in GRUB, ubuntu startup disappeared and not you can access Linux again.
I finished these tests very late and only tonight I’ll test your tip after reinstalling Linux again and then I’ll post the results here

Following @ElectricDandySlider’s suggestion to search on the It’s FOSS site, I found this @abhishek tutorial - Fix Grub Not Showing For Windows 10 Linux Dual Boot and I would like to try it too although I didn’t want to mess with WIN installation

Thanks for the support

2 Likes

Thanks @Tech_JA for the update and sorry I was not able to help.
Your posting gives lots of detail which is good b/c other may be able to learn from what you are doing.
Keep us posted. It will be interesting when you find the solution and post it here.

3 Likes

I’m definitely doing something wrong when installing Linux Mint.
After using boot-repair to recover linux boot I have now 2 boot options: ubuntu and Windows Boot Manager
If you choose ubuntu for the first boot option, when booting I get the grub menu. If I choose WIN and after load reboot, the ubuntu boot option still remains and I get grub menu again (the expected behavior using grub).

boot_1
when i installed Linux MINT just had the ubuntu boot option. After choosing run WIN in grub and rebooting, the ubuntu boot option appeared and the Windows Boot Manager option appeared and lost access to grub and Linux.

boot_2
Now after used boot-repair, I have both boot options and don’t change after WIN reboot


I will install again Linux Mint to try to find what I’m doing wrong



EDIT: After reinstall Linux Mint, efibootmgr not show **Windows Boot Manager**:
jorge@PC-JA:~$ sudo efibootmgr
BootCurrent: 0000
Timeout: 1 seconds
BootOrder: 0000,0001,0003
Boot0000* ubuntu
Boot0001  UEFI: Built-in EFI Shell 
Boot0003  Hard Drive
2 Likes