Looking for Zorin OS and Elementary OS users

distribution

#1

I have used Linux for several years now but I am still having problems with Linux Mint 19 Mate. I have problems with PDFs. I thought I had solved the issue but I still cannot print PDF I make myself or ones I open from the internet. I never had problems with this when I used Ubuntu 14.04 and 16.04, in fact they both worked out of the box and I still think the Ubuntu 14.04 was the best and most reliable OS. With Mint I to have to find ways work rounds for basic stuff like PDFs and for me this just isn’t acceptablle. My question is do we have any Zorin 12.04 or Elementary 5 users here? I would be interested in your thoughts on these systems and how they perform with PDFs. I have already tried three different systems and they all had similar issues with PDFs. It seems that It seems that many of these OSs are more focused on the latest technology but forget the basics.

cpast


What Linux Distro is the Simplest and Most Faithful to the Core Linux Principles
#2

Until one of community answers have a look here and see if it answers anything for you; https://distrowatch.com/table.php?distribution=zorin I did take a look at once, but not an indepth one so can’t help beyond that.


#3

Thanks for that, most helpful. Hopefully someone who is actually using Zorin 12.4 can tell me if it prints PDFs without issues or work rounds.
CPAST


#4

Hi cpast,

I’m a Mint 19 Mate user and have no problems printing pdfs. You might want to take a look at how you are communicating with your printer. I have a Brother HL-5450DN and have never had an issue like yours. I’ve been using Ubuntu from roughly V.5 and recently switched to Mint 19 due to issues of other kinds with Ubuntu.

Changing your distro to solve this problem is certainly overkill.

The app I’m using is xreader, which can be found at https://github.com/linuxmint/xreader/. You might want to give it a try before tearing your hair out. Cheers!


#5

My printer is a Brother HL-L2365DW monochrome laser printer. I could print anything with that when I used Ubuntu with Unity desktop straight out of the box. I deserted Ubuntu when they ditched Unity. I have tried XPDF viewer but that did not work. I also downloaded cups pdf printer from the software manager but no go there either. I will try X reader and see if I have any joy. Thanks for the tip. I will report back if I have any joy.

cpast


#6

My home printer is a Brother (MFC 9335 CDW) and it works out of the box in Ubuntu 18.04 and 18.10 - in fact - it just installs automatically after it finds it on my LAN (in the background, by stealth :wink:) … it was a manual step in Ubuntu 16/17 (involving downloading drivers)… but since Bionic Beaver it just works… and knows I’m in Australia and we use A4 paper here not letter… sweet… no interventions whatsoever… when I go to print for the first time on a new build - it’s already there!

And I’m pretty sure it was the same in elementary 5.0 “juno” (which is based on 18.04). I’ve tried elementary on and off over the last 4 years… but always run into insurmountable problems which find me back at Ubuntu… I tried Juno again recently, but just too many things I didn’t like so I wiped it and installed Ubuntu 18.10.

I do miss Unity - but last time I looked at it - things like Nautilus seemed too clunky after being in Gnome for 18 months… so I’m happy with Ubuntu + gnome 3.x - and liking the look and feel of Cosmic Cuttlefish… use it all day at work…


#7

I did already have xreader in my computer it was in the soft ware manager but did not work so I downloaded a zip file from github and on opening there was all sorts of things there but I hit the install button thinking that would do it but no, all I got was another lot of gobbley gook open in Libre office (?). but nothing installed. I must admit I am losing patience with Mint mate. This sort of thing should work out of the box as it is a basic computer operation.
cpast


#8

I am in Australia too and after using Ubuntu 14.04 and 16.04 with no issues at all in any form, I rejected the 18.04 version because I read a review that said that the right click functions did not work (copy too, create a file etc) and that was no good for me. Also a friend of mine did install it and spent ages trying to format it and get it to do basic functions. I have read good reports on Zorin but I would like to hear from someone who actually uses the 12.04 version who can tell me how it handles PDFs


#9

what about booting it live and giving it a quick test run?


#10

Yes I could do that bit it also occured to me that the version of xreader in the software manager may not have been updated in awhile so I was thinking of deleting it and reinstall using the terminal but I cannot find any terminal command to do this. Do you know what it may be?

cpast


#11

@cpast

sudo apt install --reinstall xreader

#12

i was curious about what the most recent version of xreader might be so i was reading their page on github (still looking for version #). down near the bottom of the readme, they have listed the info below. disclaimer: i don’t use xreader or poppler. i just thought that might help with your pdf issues.

Optional Backend Libraries

from:


#13

Done but still not working. Only prints the first page.

cpast


#14

I am sure the Poppler PDF viewer is XPDF and this did not work either

cpast


#15

I had thought of Sumatra pdf which came to the from the back of my mind I don’t know if it is available for Linux. Then I thought of this site for more choices: https://alternativeto.net/software/sumatra-pdf/?platform=linux it might be worth checking their suggestions out


#16

there is about five or six of those viewers I have tried and none of them talk to my printer yet the printer works fine for ODT files that I type myself and Wikipedia stuff.

CPAST


#17

I don’t know if this helps but I downloaded PDF Studio Viewer

Don’t panic about the Microsoft banner. They aren’t involved.

I found native support for PDF’s poor first on Elementary OS and now on Mint. However, I have had no problems printing anything. Just that you have very few options when working with PDF files. In particular this is the only software for Linux that I have found that allows you to view layers in PDF’s!


#18

I assume, there are no editing options?


#19

You can annotate to your hearts content but to actually edit you have to buy the full version which is expensive. If anyone knows of a reasonably priced alternative that would be interesting.


#20

I’ve used Mint 19 and 19.1 with my Brother laser printer with no issues at all, so I doubt it’s an issue with the OS. What print driver are you using? Did you install the one from the Brother site? The generic Linux driver is ok but the one from Brother is more robust. You didn’t say what was happening when you tried to print a PDF. Does it hang up at some point, give you an error or just look like it’s going to print but never does. It kind of hard to solve here because we can’t duplicate your problem. So the more info you can give the better chance you have of someone here having a solution for you.