Stuck in GNU GRUB after Linux Mint 20.2 MATE Install

I have just finished installing Linux Mint 20.2 MATE on my old PC, which previously had Ubuntu on it only. The installation went smooth, or so it seemed, it finished, asked me to restart, asked me to remove my bootable USB and press Enter, and after doing so it rebooted and now it’s stuck in GNU GRUB.

If I type exit it just loops to another fresh grub window (or however is called). I have also tried typing a bunch of other funny things like login, quit, start, ls - this one obviously does something but it does not help me fix things, mint - saw this on some forum somewhere and gave it a try, I tried my username also, and nothing works. Pressing Ctrl+Alt+Del restarts the systems but that does not help either. I’ve also powered off and back on, forcefully barbaric, from the BUTTON - same result.

Have I already destroyed my old PC? :laughing:

I will try to do a fresh Linux Mint Install tomorrow and see what happens, but if anyone has any ideas as to why this happened so I can avoid it in the future, please share those ideas.

@LeanLin
You will more than likely have to chroot back into your install and reinstall and
update grub, never reboot until grub is installed and updated. I use a Rescatux
Super Grub2 disk for that purpose. Boot the cd and it will find any /boot/vmlinuz
img to boot and even Windows.

Hi there, @4dandl4 , thank you for the tips. I have proceeded with trying them, I just have some questions regarding the whole thing, since I’m very new to Linux and I am clearly having no clue what I’m doing here.

So how should this Rescatux process look like? I tried the following and got the following (see images below - I think, no idea how image upload in posts look like, it’s the first time I do this on this forum).

So here is where the computer remains and nothing else happens further.

Previously today I tried some code lines in this grub I was stuck in, guided by my brother-in-law (he’s Linux admin, just has very limited time on his hands to help and he’s nowhere near the city I live in to come in person and handle the PC, so here I am), and I was told that my kernel is in panic mode (maybe for all of you experienced Linux users here this is something serious, but I am personally bursting into laughter because I find it hilarious, but that’s just me). During this code trying I did saw this vmlinuz thing somewhere and we tried several things, none of which worked though. He also said that during boot the system cannot find the kernel.

So is there a way to fix this or is my old computer forever gone, R.I.P.?

P.S. sorry for my lack of Linux jargon, I don’t know it yet. And for the poor image quality, my hand was being assaulted by my baby girl (the ultimate hacker of all times, she is).

@LeanLin
You say old computer, can you provide some specs?
Download ISO from here Rescatux
I have mine burned to a bootable CD-R. Boot the pc with the CD
and I usually chose the first option and let it search for any vmlinuz
images, hopefully you have a vmlinuz.
super_grub2_disk_hybrid_2.04s1 is what I use. Mine is almost two years old
and still works great, I use it almost every day.

@4dandl4 I can only tell you what MB my “old computer” has, since I am unable to turn it on. It’s an FM2-A55M-E33. I made the configuration 7 years ago roughly, is not THAT old, is just “my old computer” since I have a new one for a couple of months now.
But this is my BIOS now:

My old computer has no CD-ROM, I burned the Rescatux ISO on an USB, as it was mentioned here, using Etcher. I booted the PC with the USB and had the above shown Rescatux menu, tried both first and second option and got the same result, which is shown in the second photo from my previous reply.

Below are the codes we (me and my brother-in-law via Signal) tried earlier today:

first we tried this:

  • set prefix=(hd0,1)/efi/grub
  • set root=(hd0,1)
  • insmod linux
  • insmod normal
  • normal

- nothing happening here


below trying to find the kernel

  • ls (hd0,1)/efi/
  • ubuntu/ boot/
  • ls (hd0,1)/efi/boot
  • bootx64.efi fbx64.efi mmx64.efi
  • (hd0,1)/efi/ubuntu/
  • error: can’t find command `(hd0,1)/efi/ubuntu/’.
  • ls (hd0,1)/efi/ubuntu/
  • grubx64.efi shimx64.efi mmx64.efi bootx64.csv grub.cfg
  • ls (hd0,2)/
  • error: disk `hd0,2’ not found.
  • ls (hd0,msdos1)/
  • efi/
  • ls (hd0,msdos5)/
  • lost+found/ boot/ swapfile etc/ media/ bin dev/ home/ lib lib32 lib64 libx32 mnt/ opt/ proc/ root/ run/ sbin srv/ sys/ tmp/ usr/ var/ cdrom/
  • ls hd0,msdos5)/boot/
  • efi/ grub/ System.map-5.4.0-74-generic config-5.4.0-74-generic initrd.img initrd.img.old vmlinuz vmlinuz-5.4.0-74-generic initrd.img-5.4.0-74-generic
    he said we found the kernel
  • set root=(hd0,msdos5)
  • insmod linux
  • linux /boot/vmlinuz
  • initrd /boot/initrd.img
  • boot

- PC restarted instead of booting - and went back to grub


Afterwards my brother-in-law suggested I could try setting the PC from BIOS to boot from something other than UEFI. Mine was and still is set on boot mode: Legacy+UEFI. My only other option is UEFI, so I made no changes there afterall.

Then he suggested I should repartition the harddrive via Linux Mint install - Something else option, and I did that as he suggested, making a partition with 1GB type ext4 as /boot, one partition 4 GB type swap and the rest storage space as partition ext4 as /
like this:

This also did not fix anything. After apparent succesfull install, at the restart where I’m supposed to remove boot device and press ENTER the PC got stuck here:

with my keyboard not working and PC keep restarting after the 30 sec countdown (or 20, I don’t know)

Then he suggested I could try booting Ubuntu again, since that was working before, except for having problems with the screen, due to incompatibility between Ubuntu and AMD graphics card. Tried that but did not work, after selecting the boot media and reaching the boot menu, my keyboard did not work (I assume) and was unable to move forward with the booting.

Put your sub key in and try to boot to that
If that works try the install process again
That should sort the grub issue out

New install should fix issues like this

I can and cannot see what I need. #One is you really do not need the /boot partition,
and if you do it should be ext2 and only about 200MiB. Mint will run nicely with only a
a / ext4 partition, with the boot flag, and a little swap. I also see mount points for /boot and /, but no boot flag on /boot. Also is the drive msdos, for bios boot or gpt, for efi boot.
I am not sure Rescatux works booting from a usb, I only use a CD.


This my Gentoo, but Mint would be the same on a msdos HDD. Notice the boot flag
and ext2 on /boot.
Their is nothing wrong with what you have, but it is easy to miss that boot flag with the
Mint installer.

@callpaul.eu - I would gladly try that, if I would even know what it means to put my sub key in and boot to that. If you could explain how, I would appreciate that. Very very new to Linux, but I will definetly know a lot more once I’m done with this situation :sweat_smile:

@4dandl4 - so I’ve repartitioned the drive as per your instructions, almost. I made only one ext4 with the remaining storage space (no particular reason, I guess I was afraid that having two ext4 would cause issues), after the 200MiB and 4GB partitions, ext2 /boot and swap. Also in my partitioning menu I have no Flag column, nor the option to set anything with a “flag” word in it. So I’m either unable to flag anything, or it’s hidden from me and it’s done in the backround secretely.

After this repartitioning and new Linux Mint installation, my PC managed to react to my keyboard at the grub menu where I’m supposed to select and press enter to boot into Linux, only the system does not move forward, it restarts and goes back to the selection pane.
Second time I tried the Advanced options for Linux and it took me to a different selection pane where I was able to select either Linux Mint 20.2 MATE with Linux 5.4.0-74-generic, or the same thing but in Recovery Mode. I first tried the simple version and it did nothing, restarted and back there I was. Then I selected the recovery mode version and now I’m in the recovery menu trying to figure out what’s the next step.
I did, at the suggestions of my brother-in-law, select the “root” option in recovery menu, but it did nothing, just reloaded the recovery menu - and I am now looking at the recovery menu and waiting for suggestions :grin:

Here is my recovery menu:

Error on my part sub should read usb… spell checker changed the word and did not spot it.

Given you have got to the advanced menu
Updating the grub will help

Then restart resume will get you into mint in theory

Once you have repaired the grub should not need it again

But I have a Mac and it has never sorted the grub part so I have to do advanced recovery every time, gave up on 're install after several tries, my problem is the graphics driver on the Mac causing my error

Try the root shell prompt and run update-grub
I am going to send you another partition scheme layout that is more to what
you were trying to do. This layout will work with most any distro that supports
hdd with msdos partition table. The boot flag should enabled by the installer on
the partition that is used for the install. The boot flag is needed for setting which
OS you want to boot first, if running multiple OS’s


This is Ubuntu Mate with four primary partitions, the max for msdos. Take a look
and comment back if you have ?. Most any distro will run on one partition layout,
except, for users that are using gpt and efi boot.
The important thing when installing any Linux distro is to open a terminal and run
the update-grub command before rebooting.

@callpaul.eu so I did the update grub and it seemed to work, briefly. I got into Linux and got the nice Welcome to Linux Mint welcoming screen. It did not last though, after shut-down and later a turn back on I was back into grub looping. (I think I know understand that I was supposed to update grub from terminal once I was in there)

@4dandl4 I tried the root shell prompt from the recovery menu, but I guess I should have selected the command option instead of continue.
Since I’m so new to Linux and understand even less about this ext2, ext4 things, it is unclear to me, well, the advices I get.
You say I should make it ext2 with roughly 200MiB, my brother-in-law sais it should definetly be ext4 with roughly 1GiB. No one explained previously why is what, so until now I got this information about this ext2, ext4. So he sais ext2 is not a journaling system and because of this a recovery won’t be possible in case something goes wrong at some point, and that is why I should use ext4 instead, with more than 200MiB for all the kernel updates, which he claims will soon make that partition full and then it’s the end of it (or something, it was actually not explain, I just got a “…”).

Now I have tried the ext4 yesterday and I couldn’t move further with the install so I’m obviously confused.

I will try again to turn the PC on to see if I manage to get into Recovery Mode and into Linux and update grub from the terminal and if that fixes anything.

Will get back here with info afterwards.

I feel the need to appologise for the inconvenience I’m causing, at the sime time to thank you both so much for the lots of fun I’m having here with “my old computer”. :grinning_face_with_smiling_eyes:

For me it’s a pleasure to work on technical issues and encourage new members of our community to Linux.

2 thoughts
Mint exists on 3 versions … I find that mint mate is more forgiving than the other versions
Also I have found on some older machines the 32 bit version is even more forgiving even on 64 bit machines and for normal use you can hardly tell, speed may be slower depends on what your plans are, also the 32 bit is older version 19
But it’s chromium not chrome for the browser… hence some limits

So the latest situation looks grim. But I don’t know these things so maybe it’s just peachy.

Did not managed to get into Linux without going through the recovery mode menu first. This time I went into shell root and made an update-grub. I got this:

update-grub shell - 01

then, just to be sure, I did an update-grub from terminal once I was in Linux before rebooting.

update grub - terminal

I see no errors so I consider that a good thing.

Still, I cannot log into Linux without having the PC restarting on its own a couple of times before it shows me a boot pane where I MUST select the advanced version, otherwise it freezes, and further on again a MUST to go into recovery mode otherwise it freezes.

And now after the last reboot (I tried a few reboots and even shut-downs just to test if nothing changes) I get this and here it stayed (turned if brutally off from the button, it’s late and the ventilators of this PC are louder than I can now handle)

So I guess I’m done for the day with the destruction of my old computer. I shall continue tomorrow, that is, if anyone has anymore ideas that they wish to share with me.

P.S. I saw I said once “harddrive” and that was wrong to say, I have a feeling that is an important information, my PC has SSD. I just called it a harddrive by default, no other reasons, I was just used to saying “hard-drive” and not “solid-state”.

So good night all! Or good morning and have a nice day! depending on your own time zone.

Woke up too early this morning and had much too much time to play with my linux machine.

Here are my biggest questions:

Could it be the video drivers, or graphics card that’s causing the issue?

Read on the Linux Mint help guides that soem graphics card don’t work well with Mint and therefor one must install in Compatibility mode, which is my case also, don’t know if I mentioned it before. Other option does not work.

Or could it even be the monitor itself? (recently purchased, old, used and cheap, but it seems fine)

So I managed to log into linux mint via recovery mode, where I did a fsck, a dpkg and via root shell an apt-get update followed by an apt-get update --fix-missing (dpkg report suggested so). I got the following:

After this I did an update-grub, figured it couldn’t hurt, and then resumed normal boot and got into Linux.
Here I got the nice welcoming screen, a few minutes later the Updates available promt, and decided to check that out. A lot of updates available, most of them with ubuntu in the version name, it was confusing since I technically have only mint on the system, but what the heck, went with it.

Afterwards I did another update-grub in terminal, and look, a new set of vmlinuz and initrd. I don’t know how that happen, or if it’s a good or a bad thing, but I obviously did something so I’m proud of myself.

Again, after updates I reboot-ed, and the same old story repeats and I cannot login, except through recovery mode (if I even get there and it doesn’t freeze before, and needs a forced shut-down).

So I decided to install ubuntu again, this time the version that’s supposed to be good with my AMD graphics card. So I started the install, seemed to go normaly. I also decided to install ubuntu alongside linux mint, thinking that maybe so I can find more info on forums to help; I did notice most posts on the mighty web are about two OSs and very little, to none, about a single clean linux version on a clean PC (it was afterall formated at the first ubuntu install so I consider it clean).

Then I got this error:

with this error report:

wanted to send the error report but I didn’t manage to login into my Ubuntu One account, so I didn’t. It all ended with this notification of the failed installation:

after which the PC loged into a sort of ubuntu and it’s been there ever since. Had no time to write the post sooner, my tiny catastrophe woke up. I’m also in no rush anyway, my old PC is “redesigned” for Linux trials and it is not in use otherwise.

Any thoughts?

By the way, I started the whole Linux Mint install instead of Ubuntu because I was unable to change the screen resolution in Ubuntu, the highest available was 1024x768, and the other option was 800x600 and all the pages/windows were cut, and yeah sure, I could see them if I moved them with the mouse left and right, but that’s no way to work… According to my monitor’s specs, it’s supposed to handle 1680 x 1050 (actually recommended to have that). I tried some terminal codes found somewhere online (can’t exactly remember how they go, read alot about it before to make sure I don’t damage anything) to add more resolution options - it did not work though, and since I kept reading that ubuntu is having a permanent war with AMD graphics card I normally assumed it’s because of that. It was suggested to me to try Linux Mint because this one doesn’t have an issue with AMD.

Even so, in this Linux I managed to log into a couple of times via recovery mode menu, I checked the resolution and its option, and it was not much different. I had 1280x720 and two other options, lower resolution. It did not bother me greatly since I was seeing the whole window on the screen as supposed to, just in bigger, but still confusing that I could not select the recommended resolution of my monitor - which led me to my question above about the monitor and/or graphics card.

I would say, no. I have experience with broken and really old monitors. When they are broken, they either show weird colours (although, this can also be caused by something not related to the monitor, however it usually looks different) or just turn off unexpectedly. However, they do not interfere with how the OS operates.

Yes. Whenever there is an optical issue, like black screens, weird fonts, weird colours, weird boxes, artifacts, pixels, which is clearly not connected to the monitor hardware, it’s best to look for graphics card hardware and software issues.

I would try changing or temporarily removing parts of PC equipment. For example, switch out the hard drive or stop using the dedicated graphics card, if there is an iGPU available.

@LeanLin
From your screenshots I believe, if you can get back into Mint is to do a
sudo nano /etc/default/grub. and edit a few settings and then do a sudo update-grub.
Like I said you can run Linux without the /boot partition, install grub in /dev/xxxx and boot
parameters will be written to your / partition. Your bro in law is wrong about .ext2, the only
thing that is stored in /boot are the boot parameters. If one is using multiple distros, then the
/boot can be increased to say 500Mib, anything more is a waste. I will try and get a
screenshot of my /etc/default/grub. Do not give up, I do believe you are close. Have a good night!!!

@LeanLin
That is a good thing, it means apt is working and you are getting updates.
If you notice you went from kernel 5.4.0-74 to 5.4.0-86 so you have another
grub entry to boot from, I always keep two. You can type uname -r or uname -a in a terminal and see what kernel version is being used.
Now open a terminal and type lspci | grep VGA to find info about your
graphics card. The | is the pipe entry that is above the \ back slash key.
Also type sudo nano /etc/default/grub and do a screenshot, their are a few
things their that need to be edited.

@4dandl4 So here are my first Linux OS screenshots of what you asked. It’s not really booting right, but I can still login via Advanced + recovery mode. I did not even try the simple version out of fear of freezes and loops.

They look much nicer that photos took with a mobile phone.

You said I should edit a few settings, but I have very little clue as to what I’m seeing so I’m afraid to make changes unless someone tells me what would be no problem to change.
I could change the quiet splash into nomodeset, would that be a good change?

Regarding the kernel version, this time (first I hope and not this only time) I even saw the two kernel version at boot and was able to select which I wish to boot into. So that was nice!

@Akito So good to know is not the actual monitor. I was thinking also that it should not be, but I ran out of ideas. Also, I don’t have black screens or any optical issues just optical annoyances of restart loops. I read on some other forums, can’t even remember which and how many, that the video drivers or the graphics card could cause problems at boot.
The part with removing parts of the PC confuses me. I only have one SSD, if I remove that there’s nothing there. How do I find out if I have an iGPU available? I mean I don’t remember if this PC has a tiny PCBA that’s a graphic card or is just what the MB has. I could look, at some point. Moving the PC in any direction is an option I would like to postpone for after we’ve relocated into the house that’s almost finished from the tiny crowded apartment we are now living in. It may sound silly, but as much as I love taking electronics apart (and I really really do), I do prefer doing so in enough space with a table and places to put tools on and the such.

And by the way, if I keep booting my PC into Linux Mint via Advanced + Recovery does it damage anything? Cause I’m not particularly bothered by that, but it feels like it stresses the OS.

And yay!!, I’m posting this from Linux. :grinning_face_with_smiling_eyes:

P.S. my old computer is back on single OS, Linux Mint 20.2 MATE

@LeanLin
Sorry for the delay, my presence was needed for a funeral today.
I see nothing out of the ordinary with the two screenshots. I have
no idea of weather this pc is a laptop or a desktop or something in
between. If i where you at this point I would be trying an HDD or maybe
checking the ram or maybe resetting the mobo by removing the battery.
The next time you are in that treminal you might try typing startx or sudo startx
and see what it does.

Sorry to hear about the funeral @4dandl4 , my condolences.

It’s a desktop, far from laptop or something in between.
My question: does “trying a HDD” mean to change the SSD with a HDD and see if it helps? I could eventually, I think I still have its old HDD and if I remember correctly, it should still work. I remember changing to SSD before it was unusable.

I tried the sudo startx command in terminal, I’m not sure what it did. Some codes loaded and then I believe a new desktop loaded. It took less than a second. I also can not find that one Folder I created yesterday where I put the two screenshots in.
Was it supposed to do that?

*5 minutes later edit - after this startx I did an update-grub and rebooted. As before I had to go through Advanced + Recovery to get to Linux, and now it asks for my login password (before it didn’t cause I selected automatic logic at install), and typing the password does not help, it just loops through the login screen. *

*15 minutes later edit fixed that with

cd ~
sudo chown username:groupname .Xauthority

Well, it still needs a once button shut-down and then Advanced + Recovery to get to Linux. I feel it’s bad for my system to keep doing this to login. *

Bellow the system information from system reports, maybe it helps.

System:    Kernel: 5.4.0-86-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: MATE 1.24.0 
           wm: marco dm: LightDM Distro: Linux Mint 20.2 Uma base: Ubuntu 20.04 focal 
Machine:   Type: Desktop Mobo: MSI model: FM2-A55M-E33 (MS-7721) v: 2.0 serial: N/A 
           BIOS: American Megatrends v: 11.6 date: 02/12/2015 
CPU:       Topology: Quad Core model: AMD A10-5800K APU with Radeon HD Graphics bits: 64 type: MCP 
           arch: Piledriver rev: 1 L1 cache: 192 KiB L2 cache: 2048 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 30345 
           Speed: 1397 MHz min/max: 1400/3800 MHz Core speeds (MHz): 1: 1397 2: 1386 3: 4048 
           4: 4136 
Graphics:  Device-1: AMD Trinity [Radeon HD 7660D] vendor: Micro-Star MSI driver: N/A 
           bus ID: 00:01.0 chip ID: 1002:9901 
           Display: server: X.Org 1.20.11 driver: ati,vesa unloaded: fbdev,modesetting,radeon 
           compositor: marco resolution: 1024x768~N/A 
           OpenGL: renderer: llvmpipe (LLVM 12.0.0 256 bits) v: 4.5 Mesa 21.0.3 compat-v: 3.1 
           direct render: Yes 
Audio:     Device-1: AMD Trinity HDMI Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus ID: 00:01.1 chip ID: 1002:9902 
           Device-2: AMD FCH Azalia vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 chip ID: 1022:780d 
           Sound Server: ALSA v: k5.4.0-86-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI 
           driver: r8169 v: kernel port: e000 bus ID: 01:00.0 chip ID: 10ec:8168 
           IF: enp1s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 232.89 GiB used: 9.38 GiB (4.0%) 
           ID-1: /dev/sda vendor: SanDisk model: SDSSDH3250G size: 232.89 GiB speed: 3.0 Gb/s 
           serial: <filter> temp: 27 C 
Partition: ID-1: / size: 227.74 GiB used: 9.38 GiB (4.1%) fs: ext4 dev: /dev/sda5 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 5 rev: 2.0 chip ID: 1d6b:0002 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 5 rev: 2.0 chip ID: 1d6b:0002 
           Hub: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 chip ID: 1d6b:0002 
           Hub: 4-0:1 info: Full speed (or root) Hub ports: 5 rev: 1.1 chip ID: 1d6b:0001 
           Hub: 5-0:1 info: Full speed (or root) Hub ports: 5 rev: 1.1 chip ID: 1d6b:0001 
           Device-1: 5-1:2 info: China Resource Semico USB Keyboard type: Keyboard,Mouse 
           driver: hid-generic,usbhid rev: 1.1 chip ID: 1a2c:0c21 
           Device-2: 5-2:3 info: Pixart Imaging Optical Mouse type: Mouse 
           driver: hid-generic,usbhid rev: 2.0 chip ID: 093a:2510 
           Hub: 6-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 chip ID: 1d6b:0001 
           Hub: 7-0:1 info: Full speed (or root) Hub ports: 4 rev: 1.1 chip ID: 1d6b:0001 
Sensors:   System Temperatures: cpu: 17.9 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Repos:     No active apt repos in: /etc/apt/sources.list 
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
           1: deb http: //packages.linuxmint.com uma main upstream import backport #id:linuxmint_main
           2: deb http: //archive.ubuntu.com/ubuntu focal main restricted universe multiverse
           3: deb http: //archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
           4: deb http: //archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
           5: deb http: //security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
           6: deb http: //archive.canonical.com/ubuntu/ focal partner
Info:      Processes: 245 Uptime: 3m Memory: 7.06 GiB used: 922.3 MiB (12.8%) Init: systemd v: 245 
           runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Client: Unknown python3.8 client inxi: 3.0.38 
1 Like