Umts-stick not recognized at (re)boot

#1

Hi altogether,

I am experiencing the following problem:

My umts-stick (ID 12d1:1001 Huawei Technologies Co., Ltd. E169/E620/E800 HSDPA Modem) isn´t recognized at boot/reboot if it is already connected to the PC. And I mean: it isn´t recognized at all, not even as mass-storage-device.

It doesn´t appear to be a modeswitch-problem because lsusb doesn´t list the device at all.

Yet as soon as I disconnect the stick physically (if PC is already running) and then reconnect it it´s recognized immediately (lsusb-entry is “HSDPA Modem”) and I can
establish an internet connection.

The very problem is discused here: https://askubuntu.com/questions/419659/mobile-broadband-stick-sometimes-not-detected-at-all .
But I couldn´t find a solution that works for me.

Does anyone know hat could be done about it?

Thnaks a lot in advance.

Greetings.
Rosika :roll_eyes:

0 Likes

#2

I think you have your answer there in having to do that. I had the same problem with my wife’s laptop. Well not the same but it thought the power cable was the Ethernet connection, which it wasn’t as we’re wireless. So the only way we could get her connected was to disconnect that and then once established a wireless connection put it in. The problem doesn’t seem to be as bad with Mint 19.1 and only happens occasionally now. So that would be my only bit of help I could give you here.
Perhaps someone else can give a better bit of help

0 Likes

#3

is that the same stick from your january post?

0 Likes

#4

Hi again,

@cordx: Yes, it´s the same umts-stick. But the problem I´m referring to now is a bit different. Never mind. It seems that physical disconnection is the only way to go for the time being.
However I´ve got a hama-hub with on-/off-switch, which at least gives me some sort of convenience.

Rosika

1 Like

#5

@ElectricDandySlider:
Thanks for sharing your experience.

Interesting. I didn´t know there was such a difference between operating systems in that respect.
For now a hub with on-/off-switch provides me with a bit amount of help.

Rosika

3 Likes

#6

@Rosika,
I have a problem with USB with suspend mode and I made a script to solve the problem.
Maybe I could try to adapt my script to your issue

Could you post here your lsusb after power on and you lsusb after reboot (don’t remove umts-stick)?

Your distro is Lubuntu 18.04.2 LTS 64 bit, correct?

EDIT:
This issue happens when you power on ( boot ) too?

1 Like

#7

i came here to say this reminded me exactly of your previous situation :slight_smile:

USB 2.0 ports doesn´t works after suspend mode

1 Like

#8

I think that was @Tech_JA who asked that question not @Rosika if I remember correctly. While they’re similar questions I think @Rosika has a slightly different problem to what was asked before.

1 Like

#9

@ElectricDandySlider,
Yes, you’re right: they’re different issues but when I tried to solve my problem, one of the tests I did was power off/on to the USB port - that’s the reason I said maybe I could adapt my script or, for example, add my script to reset the controller, I don’t know…
First I need to look both lsusb and keep in mind I’m not an expert in Linux - you know how much time I “waste” with my problem…

1 Like

#10

@Rosika,
Another questions:
You already tried use your umts-stick directly to one USB port?

Your Hub is powered not passive, correct?

1 Like

#11

You never waste time. my friend. You are pedantic and there is nothing wrong with that as it helps to give great learning experience and knowledge that you can pass on to others. Nothing is a waste of time in the process of learning something.:sunglasses:

1 Like

#12

i understood they were different issues as well :slight_smile: since i don’t have have an idea for a solution i was also thinking @Tech_JA’s answer to that one might have some application here.

2 Likes

#13

Hi to you all and thanks a lot for all your input,

@Tech_JA:
lsusb after power on and after reboot are the same: The umts-stick simply isn´t detected at all.
lsusb yields the following output:

    Bus 002 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
    Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    !!!!!Bus 001 Device 015: ID 12d1:1001 Huawei Technologies Co., Ltd. E169/E620/E800 HSDPA Modem!!!!!
    Bus 001 Device 013: ID 05e3:0608 Genesys Logic, Inc. Hub
    Bus 001 Device 010: ID 045e:0779 Microsoft Corp. LifeCam HD-3000
    Bus 001 Device 008: ID 058f:6387 Alcor Micro Corp. Flash Drive
    Bus 001 Device 012: ID 1113:3163 Medion AG 
    Bus 001 Device 011: ID 05e3:0727 Genesys Logic, Inc. microSD Reader/Writer
    Bus 001 Device 009: ID 058f:6387 Alcor Micro Corp. Flash Drive
    Bus 001 Device 007: ID 1a40:0101 Terminus Technology Inc. Hub
    Bus 001 Device 006: ID 05e3:0608 Genesys Logic, Inc. Hub
    Bus 001 Device 005: ID 1058:25a2 Western Digital Technologies, Inc. 
    Bus 001 Device 004: ID 0458:0185 KYE Systems Corp. (Mouse Systems) 
    Bus 001 Device 003: ID 05e3:0608 Genesys Logic, Inc. Hub
    Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

But without the line
Bus 001 Device 015: ID 12d1:1001 Huawei Technologies Co., Ltd. E169/E620/E800 HSDPA Modem
As I´m using a working internet connection at the moment it´s included in the lsusb-output.

Yes, that´s correct.

Yes, indeed.

Greetings .
Rosika :slightly_smiling_face:

0 Likes

#14

Yes, I´ve tried that, too. That´s what I did in the beginning. And that´s the reason why I decided to go for a hub with on-/off-switch, which gives me greater convenience.

Yes and no. The hub with on-/off-switch (that´s the one the umts-stick is connected to) is a passive one. But it´s connected to a hub with its own power-supply. So it definitely shouldn´t be a power issue there.

0 Likes

#15

another question:
Laptop or desktop PC?

0 Likes

#16

@Tech_JA:
Well, it´s a PC. But believe it or not, I had the same problem when connecting the umts-stick to my laptop.
That´s why I mentioned the page https://askubuntu.com/questions/419659/mobile-broadband-stick-sometimes-not-detected-at-all .
There it says:

This is a common problem of Huawei dongles and there is no clearly recognized fix for this. Some Huawei dongles simply switches off when you put your laptop into sleep mode

Greetings.
Rosika

0 Likes

#17

I asked that because some bios have a settings to leave USB ports powered when the PC is off

I’ll try to help you, but keep in in I’m noob in this world

0 Likes

#18

@Tech_JA:
Thanks a lot for all the effort of yours…
It´s been a while since I looked up my BIOS-settings but I´m pretty sure the problem lies somewhere in the already quoted

My first thought was to ask about this problem here in case anyone has encountered a similar one.
Nevertheless I think I´ll stick to my on-/off hub for the time being, as it provides some sort of workaround anyway.

Many greetings.
Rosika

0 Likes

#19

Just for us, I don’t like answers like you received yesterday in other forum, doesn’t matter the name of it…
In my opinion, that’s in cases like that where IT’S FOSS COMMUNITY makes the difference

I don’t have umts pen so I need you made some tests with your help
I already download lubuntu but I need time to learn - be patient please

You already have the fast answer for your solution- Use the hub switch
Now we will try to find if we could get another solution

0 Likes

#20

@Tech_JA:

Thanks a lot for all the effort of yours.
Now I almost I have a bad conscience for giving you so much work. :slightly_frowning_face:

0 Likes