Wifi Connection Problem

Hi, Following on from my question on the newsletter page where it was suggested I try connecting via an Ethernet cable.
I have tried connecting via an Ethernet cable. When the network setup window pops up, ‘ADMIN’ is the default Username and I type in the Modem password. After 30 or 40seconds the setup window pops up again when a network connection failure message pops up. Then it shows a little Ethernet connector icon as unplugged. I click to plug it back in again but get the same result repeatedly. I also get a message telling me issues need fixing. When I look it says I need to download and install Netcomm drivers. However, I can’t connect to do that. The other MINT PC didn’t require that.
I can’t figure out why the PC won’t connect to my modem via WiFi.I have 2 desktops. Both had Ubuntu 18.04 which I removed and replaced with Mint 20. Previously, both desktops connected to my WiFi modem automatically after the original install of Ubuntu with no problems. One of my Mint PCs connected automatically once the OS finished installing and I was able to update etc. The other PC which went through the identical Mint installation process but just won’t connect. Both Mint installs formatted the hard drives so there would be no legacy problems.
Any help for this confused old man would be appreciated.

can you post the output of the terminal command
inxi -Fxz
so we can get some system specs to look at?

sorry can’t do that because i can’t connect the PC to the internet and there are a lot of lines which will take me hours to type out manually without mistakes.

You can put it into a file and then transfer that file to other devices. Or you can shoot a video. There are many alternatives available.

Especially such information should be really quoted and not paraphrased, so we get to know the actual issue.

you seem to have some similarities to

Linuxmint 20 intermittent internet issue connected but no internet
it seems you have more than one connection all competing.
i wouldnt expect you to have to type in pw etc for ethernet connection.
Perhaps try, in your network connections, to disconnect all wifi and just use wire
hope you get sorted

Thanks for trying everyone. Its all too confusing for me. I tried to save the inxi output as an .odt document but then i was denied permission to save it to a dongle. I give up.
My mind is not capable of this stuff anymore.

ubuntu 18.04 will still be updated for another couple of years if you want to try and return to something that worked previously. good luck :slight_smile:

1 Like

yes. thanks. I’ll do that when its daylight daylight (I’m going blind to add to my woes)

1 Like

As an aside, my modem is on the 5G network. I run an iPad, an Android phone, Chromecast and one of my 2 Desktops (1 - the one which won’t connect - is an Intel i7, the other, an older AMD64 all on WiFi. Everything is within 6 feet of the modem. Maybe its overloaded…and I have no clue how to get everything through the yellow Ethernet cable I have (its a Type 5).

if it worked for you previously with ubuntu 18.04, that is unlikely. especially if you don’t have several of those devices all trying to download or stream something at the same time.

ok. i’ll go back to Ubuntu. Pity because I like the look of Mint.

obviously the choice to go back to ubuntu or stay with mint is yours, but i know sometimes i get pretty frustrated with a particular computer problem in the moment. i think a computer that worked with ubuntu 18.04 should be fairly compatible with mint 20 if you have some time to maybe step away from the problem for a bit and come back to troubleshooting later.

of course if you just want a system that works, i get that too :slight_smile:

1 Like

MINT 20 works perfectly on this old AMD machine, as did Ubuntu 18.04. I’ll keep it and reinstall Ubuntu on the much newer ASUS i7.

sorry if it looked as if i meant the modem was on overload. I was thinking maybe the one device was trying to connect by wifi and wire at the same time

How do I post an image here please?

when you are creating a post there is an icon above where you type that looks like a rectangle with an arrow above it. if you hover over that symbol, it should say upload. click on that and you should be given the option to browse your computer for an image:

A photo is the best I can do. Hope it’s readable.

the quality was excellent. thank you for posting that.

it might also help to see this specific message:

from the picture, i can see your wireless adapter is identified as a Broadcom BCM4352. this page indicates that there are some recognized problems getting that specific adapter to work with linux, but plenty of people seem to have been able to do so.

the page linked below discusses some ways to deal with problematic wifi drivers. if you scroll down a bit, it specifically addresses working with Broadcom adapters as well how to find the drivers if you don’t have a working internet connection.

1 Like

posting these for easier reference:

system: asustek product: ET2321I v: 0705

realtek rtl8111/8168/8411 pci express gigabit ethernet
vendor: asustek driver: r8169 v: kernel port: e000 bus id: 02:00.0
if: enp2s0 state: up speed: 1000 Mbps duplex: full mac: filter

broadcom and subsidiaries BCM4352 802.11ac wireless adapter
vendor: azurewave driver: bcma-pci-bridge v: n/a port: e000 bus id: 03:00.0

I’m sorry but I have no idea what all that means. I have noticed when I tried the suggestions in the article link posted by you that i kept seeing references to AMD. The chip in the PC is an Intel i7. Have I got the incorrect iteration of MINT installed? I installed Mint 20 on both desktops, the AMD and the Intel from the same USB drive. I got no warnings during the installation process that the wrong iteration was being installed. My modem is a NetComm 6547 not a Broadcom or Realtek.