Devuan5 init diversity edition

I just wasted a whole week trying to use the Devuan Refracta installer in virt-manager to do an install of

It loaded the live system fine, then I could start Refracta installer . It drops you into Gparted to setup partitions. I did what I normally do for VM’s and left it at the default msdos partition table, and I made boot, /, and swap partitions.
It copies all the Linux files to the / and boot partitions, no problem.
It copies all the grub config files to the / partition
then it offers a choice of how/where to install the bootloader

I choose MBR ( Partition means use an EFI partition )
Then I get a popup

So I click on OK , and it says it failed to install the bootloader.

After many repeat tries with various setups with gparted , with and without boot flags, I finally realize… I have to choose a drive, like this


before I click OK.

Then it works. Here is the Devuan init-diversity grub menu

A little better than the Antix one - you can see the first 2 characters of the init system choice on the end of each line.

Wow. That cost a week.
Why do I have to click on something when it is the only choice?

Seriously, Refracta is a good installer, just a little quirky on places.


Hi Neville, :wave:

great job you´ve done. Congratulations. :+1:

Just out of interest: where did you download the ISO file
“Devuan-5.0_xfce_init-diversity-edition_amd64_UNOFFICIAL_20240319.iso” from?

I looked here: but couldn´t find it.

Here they posted the download link but it seems to refer to the internet archive/wayback machine… :thinking: .

Cheers from Rosika :slightly_smiling_face:

1 Like

Hi Rosika,
Dont know about great job. Much time wasted.

It is in that topic, in the first post… along with the Antix and MX versions.

Dont be frightened of Refracta installer. Refracta seem to have some link with Devuan… they also produce a distro called Refracta which is a Devuan derivative.

Thanks for the cheer up


@Rosika ,
Also this link , which may be better

I should not call it edition… it is unofficial.


I see, Neville. Thanks.

In your Antix topic you posted this link: Devuan 5.0 ‘init-diversity’ edition – antiX-forum .

Looking it up they refer to Devuan 5.0 init diversity edition UNOFFICIAL 20240319 : ProwlerGr : Free Download, Borrow, and Streaming : Internet Archive .

So it´s in the internet archive again. Interesting. :wink:

Still, it´s a great job you´ve done.
I´m good with “time wasting” as well. :laughing:

Many greetings from Rosika :slightly_smiling_face:


I just noticed your second post.
So it seems the internet archive is the only place you can get it from…


To be accurate the Refracta distro has quite a longer history than Devuan.
It was originally a Debian derivative & rebased on Devuan when systemd was made default & Devuan was born.

Now the Refracta installer (not to be confused with the distro), is a piece of software available in the Devuan repos, & is the official installer supported to install from the official Devuan live images.

That is correct, this is a personal unofficial image, which I decided to share on the internet archive.


Hi to you, :wave:

thanks so much for the info. :heart:
It´s highly appreciated.

Wow, I´m impressed. Thank you for doing that.

Have a nice day and many greetings from Rosika :slightly_smiling_face:


Thanks for clarifying that.

Do you have any idea why the grub menu entries for the installed version are truncated? The live grub menu is OK.

1 Like

They’re not truncated, but you’ll need a higher resolution than the virtualbox 640x480 to fully view them.

I am goi g to focus on the s6-rc init system in Devuan 5

Lets try to do something. First get it up to date

apt-get update
apt-get upgrade
root@init-diversity:/home/nevj# apt-get upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 grub-pc : Depends: grub-common (= 2.06-13) but 2.06-13+deb12u1 is installed
           Depends: grub2-common (= 2.06-13) but 2.06-13+deb12u1 is installed
           Depends: grub-pc-bin (= 2.06-13) but 2.06-13+deb12u1 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

So it does not quite have its package setup right

apt --fix-broken install
it works

But there is a complaint about grub

which I ignore, and it goes ahead and install grub on /dev/vda, and all is OK. I tested a reboot… the multi-init-grub-screen is still there.

Now let us see if we can install a new service

root@init-diversity:/home/nevj# apt-get install vsftpd
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 26 not upgraded.
Need to get 142 kB of archives.
After this operation, 351 kB of additional disk space will be used.
Get:1 daedalus/main amd64 vsftpd amd64 3.0.3-13+b2 [142 kB]
Fetched 142 kB in 3s (56.2 kB/s) 
Preconfiguring packages ...
Selecting previously unselected package vsftpd.
(Reading database ... 279933 files and directories currently installed.)
Preparing to unpack .../vsftpd_3.0.3-13+b2_amd64.deb ...
Unpacking vsftpd (3.0.3-13+b2) ...
Setting up vsftpd (3.0.3-13+b2) ...
invoke-rc.d: could not determine current runlevel
Processing triggers for man-db (2.11.2-2) ...

Well it did something. Lets look and see what is there

nevj@init-diversity:~$ ps ax | grep vsftpd
 5950 pts/0    S+     0:00 grep vsftpd

No it is not running
What is in /etc?

nevj@init-diversity:/etc/init.d$ cat vsftpd

# Provides:		vsftpd
# Required-Start:	$network $remote_fs $syslog
# Required-Stop:	$network $remote_fs $syslog
# Default-Start:	2 3 4 5
# Default-Stop:		0 1 6
# Short-Description:	Very secure FTP server
# Description:		Provides a lightweight, efficient FTP server written
#			for security.

		echo "Usage: ${0} {start|stop|restart|reload|status}"
		exit 1

That is a sysVinit script for vsftpd.
That is what Devuan normally does - its package system installs sysVinit scripts for services.
Is there anything else?
There is no vsftpd directory in /etc/s6-rc/sv
So I am on my own… have to write an s6-rc script.
Never written one… have no instructions… lets try copying one and modifying it.

oot@init-diversity:/etc/s6-rc/sv# mkdir vsftfd-srv
root@init-diversity:/etc/s6-rc/sv# cd vsftfd-srv
root@init-diversity:/etc/s6-rc/sv/vsftfd-srv# cp -r ../sshd-srv/* .
root@init-diversity:/etc/s6-rc/sv/vsftfd-srv# ls
producer-for  run  type

type is OK , it is longrun
producer-for contains sshd-log… we dont want a log …we will empty it
run needs editing

#!/bin/execlineb -P
##if -t { test -s /etc/vsftp/vsftpd_not_to_be_run } exit 161
foreground { mkdir -p /run/vsftpd }
foreground { chmod 0755 /run/vsftpd }
foreground { redirfd -w 1 /dev/null ssh-keygen -A }
foreground { touch /var/log/lastlog }
foreground { chgrp utmp /var/log/lastlog }
foreground { chmod 664 /var/log/lastlog }
envfile /etc/s6-rc/config/vsftpd.conf
importas -sCuD "" OPTS OPTS
fdmove -c 2 1
exec /usr/sbin/vsftpd  ${OPTS}

There a a few guesses in there.
Reboot, and it is still not running.
OK, still learning… S6 is not as easy as runit… maybe that run script needs to be somewhere else ( like current or whatever) … maybe I need a link like in runit??

First lets see if I can start it by hand ( it did not start at boot).

root@init-diversity:/run/s6-rc/servicedirs# s6-rc -u change vsftpd-srv
s6-rc: fatal: vsftpd-srv is not a recognized identifier in /run/s6-rc/resolve.cdb

So there is more to it than that.
I fear that putting a directory in /etc/s6-rc/sv is not enough… I need it in
what S6 calls the scan directory , which is /run/service. In there are a whole lot of links to files in /run/s6-rc/servicedirs/ ie the scan directory is a link-farm.

So I will try putting a copy of the vsftpd-srv directory in /run/s6-rc/servicedirs/ and make a link from /run/service

cp -r /etc/s6-rc/sv/vsftpd-srv  /run/s6-rc/servicedirs
ln -s /run/s6-rc/servicedirs/vsftpd-srv /run/service/vsftpd-srv

reboot , and it is still not running
Try to start it now

root@init-diversity:/home/nevj# s6-rc -u change vsftpd-srv
s6-rc: fatal: vsftpd-srv is not a recognized identifier in /run/s6-rc/resolve.cdb

So it still fails and same message.
I think I need to do something about compiling the s6 database
Will close this now
Try again tomorrow


Try running

sudo s6-db-reload

(a simple script I wrote)

Also a good resource for s6-rc services can be found in the Artix gitea (look here before attempting to write your own)


I will also add that a good resource for 66 service frontends can be found in the Void linux github:


Will try… and Inwant to read that script.
and thanks for the Artix Gitea link.
I will get there, it is just that the s6 documentation is not very helpful. I want to master s6-rc before attempting s6-66.

Do I need to add my vsftpd service to the default bundle?

I have a hard install of Artix with s6. It is set up much better than Devuan… most of the Artix packages have an associated s6 script package and when you install the script package it deals with all the s6 mansgement issues.

You could have made a better performing init-diversity spin had you used Artix. Is there any chance of that?



Void is one of my main distros. I use it a lot , but with the standard runit init.
So there is work proceeding on s6 for Void. That is interesting.

If you have created the source script, you could just use the GUI to add it to the “antix-service-manager” bundle which is already part of the “Default” bundle.

OK, I can , but it is not essential. Correct?
Bundling will not avoid the database problem?

Correct on the first point.
The GUI automatically compiles the database for you, but it is set-up to manage the ‘antix-service-manager’ bundle only. It cannot manage services outside it.
So on the second point the end user avoids the database problem because it is automatically handled (not because compiling is not needed)

You are talking about the Antix GUI.
This is Devuan.
I could switch to Antix and do what you suggest… the GUI is great… but I want to learn something so I will try a compile in Devuan.
What is really inadequate is the documentation for S6. There are few examples for anything other than simple start/stop commands, or where there are small examples they are not explained. They need some example tasks

The GUI (authored by myself) is also present in my Devuan spin. It should be under the Preferences menu - or - by running



It is virt-manager. Not sure what resolution it uses, but it uses spice.
I think the grub menu uses elementary vga graphics from the BIOS…
Not sure how to access the BIOS in a VM setup. I think it is set up by the
KVM Hypervisor.

Dont bother, I can live with it.