I have a HP p6506f with a Ralink RT3090 Wireless chipset

I have a HP p6506f with a Ralink RT3090 Wireless and it seems that RT3090 is not compatible with LINUX.
Here are the results to the commands.
I had to edit the output because it wass 81733 characters long when the max is 32000 characters.

I directed the output of each command into a file and copied them here.

-> Output of inxi -Fxz here!

System:
Kernel: 5.4.0-26-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
Desktop: MATE 1.24.0 Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal
Machine:
Type: Desktop System: Hewlett-Packard product: p6506f v: N/A
serial:
Mobo: FOXCONN model: 2A8C v: 1.0 serial:
BIOS: American Megatrends v: 6.02 date: 04/29/2010
CPU:
Topology: Dual Core model: Pentium E5500 bits: 64 type: MCP arch: Penryn
rev: A L2 cache: 2048 KiB
flags: lm nx pae sse sse2 sse3 ssse3 vmx bogomips: 11199
Speed: 1200 MHz min/max: 1203/2803 MHz Core speeds (MHz): 1: 1200 2: 1200
Graphics:
Device-1: Intel 4 Series Integrated Graphics
vendor: Hewlett-Packard Compaq 500B Microtower driver: i915 v: kernel
bus ID: 00:02.0
Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
resolution: 1024x768~60Hz
OpenGL: renderer: Mesa DRI Intel G41 (ELK) v: 2.1 Mesa 20.0.4
direct render: Yes
Audio:
Device-1: Intel NM10/ICH7 Family High Definition Audio
vendor: Hewlett-Packard Compaq 500B Microtower driver: snd_hda_intel
v: kernel bus ID: 00:1b.0
Sound Server: ALSA v: k5.4.0-26-generic
Network:
Device-1: Realtek RTL810xE PCI Express Fast Ethernet
vendor: Hewlett-Packard Compaq 500B Microtower driver: r8169 v: kernel
port: e800 bus ID: 02:00.0
IF: ens33 state: down mac:
Device-2: Ralink RT3090 Wireless 802.11n 1T/1R PCIe vendor: Lite-On
driver: rt2800pci v: 2.3.0 port: e800 bus ID: 03:00.0
IF: wls35 state: down mac:
Drives:
Local Storage: total: 728.45 GiB used: 8.67 GiB (1.2%)
ID-1: /dev/sda vendor: Seagate model: ST3750528AS size: 698.64 GiB
ID-2: /dev/sdf type: USB vendor: Lexar model: USB Flash Drive
size: 29.81 GiB
Partition:
ID-1: / size: 686.18 GiB used: 8.67 GiB (1.3%) fs: ext4 dev: /dev/sda5
Sensors:
System Temperatures: cpu: 44.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 169 Uptime: 4m Memory: 3.81 GiB used: 565.0 MiB (14.5%)
Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.16
inxi: 3.0.38

Output of dmesg_*.log is more than 77000 characters.
IS IT NORMAL?

-> Output of dmesg-err_*.log here!
IT IS EMPTY

NO VPN USED.
CAN’T UPDATE SINCE I HAVE NO INTERNET.

SO ONLY RESULTS OF THESE THE ip a COMMAND IS AVAILABLE

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: ens33: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
link/ether 1c:c1:de:5b:73:62 brd ff:ff:ff:ff:ff:ff
3: wls35: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
link/ether 70:f1:a1:b4:09:16 brd ff:ff:ff:ff:ff:ff

I don’t think so. According to the data blob you pasted,

Device-2: Ralink RT3090 Wireless 802.11n 1T/1R PCIe vendor: Lite-On
driver: rt2800pci v: 2.3.0 port: e800 bus ID: 03:00.0

The diver seems to be installed. You might try to execute the following commands in order to make it work:

echo "options rt2800pci  nohwcrypt=1" | sudo tee /etc/modprobe.d/rt2800pci.conf
sudo modprobe -rfv rt2800pci
sudo modprobe -v rt2800pci

As suggested in:

Thanks for responding to my request @Mina.
I had already tried these commands before posting.
The device is still down :

Network: Device-1: Realtek RTL810xE PCI Express Fast Ethernet
vendor: Hewlett-Packard Compaq 500B Microtower driver: r8169 v: kernel port: e800
bus ID: 02:00.0 chip ID: 10ec:8136
IF: ens33 state: up speed: 100 Mbps duplex: full mac:
Device-2: Ralink RT3090 Wireless 802.11n 1T/1R PCIe vendor: Lite-On driver: rt2800pci
v: 2.3.0 port: e800 bus ID: 03:00.0 chip ID: 1814:3090
IF: wls35 state: down mac:

I don’t know what goes wrong with your configuration and I don’t have the same notebook as you.

What is your output from sudo modprobe -v rt2800pci? If it is nothing, everything should be fine.

However, I had HP notebooks in hand a couple of times and they all had a physical WiFi switch. Do you have one? If so, is it switched on?

Thanks for the update @Mina.
The HP p6506f is a tower not a note book so NO SWITCH available
and sudo modprobe -v rt2800pci
gives nothing.

Sorry! I’m on the end of my wit.

@Roger_Gravel…I keep an old network card that I use when I cannot get a network driver to work. I can usually get the machine to work after connecting to the internet.

Although the info you posted suggested it should be working a few different ideas

Simple question to start with

Does the internet connection work if you use a Ethernet cable ?

If you go into the control panel, and check

Are there any suggestions ?

If you go into the bios settings (f2) at start up is there any mention of WiFi or network in your bios

Can you 're install the system from a usb
When you get to the point about connecting to internet with the Ethernet cable not connected does it offer WiFi connections
Yes can just do this step to check without actually 're installing

Not got the same machine to test but had one similar last week and despite trying above the reinstallation solved the issue

Hi Roger. On another thread I posted about this as it seemed it was a WLAN wireless issue with Trisquel OS rather than ubuntu linux in general. The guy over at DistroWatch was reviewing this OS and noted this incompatibility. He was testing with HP fitted with Ralink RT5390R PCIe Wireless card which I looked up for compatibility issues here…

… and even dropped the search to just Ralink …. no results at all…!

Would you consider another alternative workaround – a USB Wireless adapter such as…

Good Luck.

Edit:- Sorry - you should know as you posted here recently… which is solved.

I really don’t get it why manufacturers insist on providing proprietary drivers for their devices when all communication between device and PC can be handled easily over an open protocol and the TCP/IP stack.

With my previous desktop, I had the problem that my Belkin wireless adapter wouldn’t work any more after switching from Windows XP to Windows 10 (when I was still sometimes using Windows. Under Linux, no problem), same with many programs which suddenly refused to work because the graphics adapter (Intel!) had no properly signed Windows 10 drivers (though the same programs worked fine under XP and Windows).

Sorry for my rant, I simply don’t get it why companies want to piss off people…

2 Likes

@4dandl4 As I said earlier the p6506f has an ethernet card that I can use. The only « worry » is that I have only one 2,5 meters RJ45 cable.

@Andy2, I do not want another gadget.

I looked all around and saw that MANY individuals reported problems with this Ralink RT3090 Wireless card after instaling a new version of UBUNTO or MINT. It seems that linux uses [rt2800pci] instead of the [rt3090pci],

My next step will be to try installing ndiswrapper ; it may give me a chance to make a Windows driver from Ralink work on a Linux system.

But first I will open the box and check if the card is firmly attached to its slot ; after I will wait ti get a new 2.5 meters cable.

@callpaul.eu
Yes the ethernet card is ok and I was able to install [tricia] over [nadia] on that computer.
Matter of fact WIFI connection was working before I installed the new MINT.
BTW, according to the Control panel, after a 60 seconds ’looking for hardware drivers…’ display : Your computer does not need any additional drivers ; so no suggestions there.
BIOS SETUP UTILITY -> ADVANCED says
Onboard LAN [enabled]
Onboard LAN Boot ROM [enabled]
Onboard WLAN [enabled]

I am not certain how to do this @callpaul.eu.
Thank you for reading this.

By the looks of your reply everything should be working … strange.

I guess you did an upgrade and not a clean install ?

If sol and the WiFi was not an issue before then it was something to do with the upgrade.

Plan of action

Post a question direct to

The forum may have a further suggestion

I have found

It’s a French site, but the driver is English, partway down image of a floppy disk says telechargement (download)

Comes down in zip form but when you double click after it in packs. Again cannot check as don’t have the same.

Other options

buy a different usb WiFi key that will just plug and go, locally or on Amazon.

To do a clean install.
Download a new copy of linux mint from the website
create a boot usb
Boot to that usb
Start the installation process
about the 3rd step shows network WiFi connections
But then cancel at that stage !
We know from the results if your WiFi card is working and going to connect

Bonne courage !

@callpaul.eu

I did not make an update.
I explicitely made the choice of erasing the disk before install.

I know I am stubborn and I do not want a new gadget where a Ralink RT3090 Wireless chipset is already installed for the WIFI purpose.

I believe the fault is with LINUX MINT and I will use your suggestion and visit their forum.

But, before that, I will try to install the driver I found at the touslesdrivers.com web site.

Thank you.
p.s. I must add that
I have never seen this step

in the installation process :pouting_cat:

With a clean install it should have sorted itself if it was going to
You would only see the step on WiFi if not connected via cable

Bought a LB link from eBay for £4.99, plugged in USB port opened WiFi and found it right away , just logged on to my router as usual . It worked for me no problem .

1 Like

I have booted Ulyana with a usb/stick and in compatibility mode
the [iwconfig] command says :
lo no wireless extensions.
ens33 no wireless extensions.
wls35 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not associated Tx-Power= 20 dBm
Retry short long limit:2 RTS thr:off Fragment thr:off
Power Management: off

I looked for the RT3290 Wireless 802.11n 1T/1R PCIe
device driver at :
https://devicehunt.com/view/type/pci/vendor/1814/device/3090

and this specific driver does not exist there.

I visited the French website you suggested earlier.
I downloaded the correct zip file and
it contains the same driver linux had indtaleld : rt2860.

Would the install logs be more informative ?

If you feel up to it

Switch off the computer at the mains and remove the cable
Open the box
Remove the network card
Have a clean up inside the box of dirt … just because you are inside
Replace the card
Reconnect the cables
Reboot

Try again

I wonder if the card is faulty
Giving false results

Maybe we are at a point where
You buy a new WiFi card or usb
You use a cable
You return to an older version of mint

None solve the issue, but getting to the end of my capabilities at a distance … unless you want to drop by for a coffee and test, still no promise.

I believe my 13 year old HP G60 noteboook has an internal WLAN adapter - Realtek RTL8101/2/6E which perhaps needs no blobs and reaches my printer upstairs without issue from day one. :slightly_smiling_face:…Perhaps you could get an ebay Realtek to replace that cheap Ralink and then be compatible with the “free” and run without any problems whatsoever. :smiley:
You seem to be flogging a dead horse and making a rod for your own back at the same time ouch - n’est pas :face_with_raised_eyebrow: but wish Roger good luck all the same.