Ubuntu 20.10 Slow app Loading

Hey guys I’m new to Ubuntu and I’m facing some problems :sweat_smile:.

Before installing Ubuntu i was using Linux Mint ( i used it for two months ) everything was fine, now i wanted to try another Linux Distro so I chose Ubuntu.

Unfortunately i faced two problems the first one was Boot time it boots in 1min and half compared to Mint that boot in 1min and 10 15 seconds, well that’s not a big difference even if it’s bothering me a little i don’t care about it cause i have an HDD and it’s known that HDD is slow at booting.

The second problem (The one that’s bothering me a lot) I’m facing is Application loading time, it takes more than 5 seconds to launch for the first time, Firefox take more than 10 seconds, VLC takes 10s, Inkscape 14s-15s, while in Mint it takes less than 5 seconds (almost never reach 5s), and Firefox takes 7 - 8 seconds.

is this normal ? is there any solution for this ? I tried installing gtk2 module and i found a video in YouTube about this problem but nothing is working for me.

Here are my specs:

CPU: Intel i5-7200U

RAM: 8GB

HDD: 1TB

And Thanks in advance :pray::heart:.

Hi,

I am guessing that it could be the ‘snap issue’. Firefox should open the same, though.

Anyway, could you please provide the output of the following command:

snap list
3 Likes

Thanks for your reply here is the output :

> Name               Version                     Rev    Tracking         Publisher      Notes
> core               16-2.47.1                   10185  latest/stable    canonical✓     core
> core18             20200929                    1932   latest/stable    canonical✓     base
> flutter            0+git.4d37aa3               36     latest/stable    flutter-team✓  classic
> gnome-3-28-1804    3.28.0-19-g98f9e67.98f9e67  145    latest/stable    canonical✓     -
> gnome-3-34-1804    0+git.3556cb3               60     latest/stable/…  canonical✓     -
> gtk-common-themes  0.1-36-gc75f853             1506   latest/stable/…  canonical✓     -
> riseup-vpn         0.20.4                      161    latest/stable    leapsnaps      classic
> snap-store         3.36.0-82-g80486d0          481    latest/stable/…  canonical✓     -
> snapd              2.47.1                      9721   latest/stable    canonical✓     snapd
> vlc                3.0.11                      1700   latest/stable    videolan✓      -

I uninstalled Inkscape snap version and reinstalled the Flathub version.

1 Like

Welcome to ‘It’s Foss’ @Irenburg. Forgive me for sounding like a smart- a**, but isn’t it the reason people Distro hop (try different Distro)? To see how different versions of Linux and DE (desktop environment) feel / perform?

1 Like

@Irenburg

I’m just curious: did you try to get some information about what is actually consuming time during the boot process?

@abhishek published an article about how to find out.

However, the start times of the programs make me wonder. On my system, e.g. VLC starts practically instantly, Inkscape in about a second. Whether you’ve got a SSD or an HDD, shouldn’t matter too much. SSDs are very fast when reading or writing huge files but when it comes to opening programs, HDDs shouldn’t be too bad.

2 Likes

Yes that’s my reason too, i saw a lot of people using Ubuntu and enjoying using it so i wanted to give it a try.

After reading the article I checked my system and found that this services are taking more than 10s:

24.091s plymouth-quit-wait.service
14.020s snapd.service
12.467s dev-loop12.device
12.431s upower.service
12.303s networkd-dispatcher.service
10.187s NetworkManager-wait-online.service
10.018s dev-sda8.device

but i don’t know what to disable and what to leave.
And about launching applications, what i said is just about opening Apps for the first time, after that when i launch an App it opens instantly.

1 Like

@Irenburg there was a thread on here some time ago about boot times of their PC’s from members. You may enjoy looking at it.


It include info about ‘sudo systemd-analyze’ and ‘sudo systemd-analyze blame’. These two commands only give info for boot time as far as I know.

2 Likes

@easyt50 I tried it my boot time vary between 1min to 1min 20s.
I really don’t care that much about boot time what’s bothering me a lot is App Loading, cause I hate clicking on a video and waiting for like 7 to 10s to for VLC to open, this just only one example of what I encounter daily.

@Irenburg I found this today doing a search on slow app loading. It is right here on ‘It’s Foss’! Maybe it will help.

Maybe I jumped the gun. When I saw that it said it was solved, I thought it was a good answer. After reading the entire post, maybe not. But, you may find reading all the posting interesting.

1 Like

Snap packages don’t help either, as they are way to big in comparison to a Deb file with exactly the same app. I just hope that in the future Snap packages will get lighter and quicker. Since moving to GTK3 not everything has made the move, leaving a lot of apps not loading as they should, or having to install extra packages to compensate. Still glad you found the answer and just goes to show how heavy Gnome 3 actually is on resources. Even my Linux Mint XFCE environment boots up quick, but uses 600 or so MB of ram and that is after switching off unnecessary apps from auto starting, plus that’s on a SSD, without the Linux Mint logo Splash screen whilst booting, just the name of my ASROCK motherboard up in the center of the screen, then straight to the login screen. Even though you associate green with mint, green becomes sickly in the end hence why I changed my grub file around, so it’s booting from bios rather than the actual hard drive being in full control.

1 Like

Hi,

As you can see, you installed the Snap version of VLC. Snap apps take a long time to start.

What you can do is to use apt here:

sudo apt install vlc

and remove Snap version of VLC:

sudo snap remove vlc

2 Likes

For us newcomers, would you please either direct me to a posting that tells the different is between snap install vs apt install or port something here. Thanks

I’ll write about it in detail later.

For now, you should know that these are two different packaging system. Apt utilizes the conventional style where the dependencies are installed on the system. Snap on the other hand run in their own block, usually isolated from the rest of the system.

The way snaps are designed, the apps installed as Snap have longer start up time and often take more disk size.

I know it might not be very clear this is why I will take time and try to explain it in less technical terms in a couple of weeks.

1 Like

Here is a video that explains the differences between packages, app-images, snaps and flatpacks pretty easily. (14min)

1 Like

Thank you for the link @Mina. I must still be a bit wet behind the ears, just off the boat, newcomer, or things just don’t connect like they use to.
Now I find out there is not only DEB and Snaps, but also AppImage, RPM. Flatpak, and source code to deal with.
I’m still kind of new to Linux (about 2 years now) and I suppose I was looking for a way to “trust” a software package that I might be thinking of installing. In Windows, I use to always run a virus scan on the download before installing.
Maybe it not as simple in Linux. But I get the feeling that packages install via deb can be trusted. Maybe I’m wrong. It looks like LM does not trust snaps?
Like you said in another posting elsewhere that it’s a personal choice & responsibly to review / look into the software a person installs on their system. I suppose I was looking for an easy way out.

@easyt50 Please don’t drive yourself mad. Despite the valuable remarks by @Andy2 and @Akito in Large Updates you shouldn’t make your life more complicated than it needs to be.

If I were you, I’d go, whenever possible, with your software centre or your standard repository via sudo apt install xyz.

The main things you should avoid are installing software from dubious sources or typing in some random commands, just because some guy (or chick :wink:) on the internet tells you to.

I guess, you use your computer for entertainment and productivity. In that case, you shouldn’t hardly notice which operating system you are on.

In case you really want to dig deeper, nobody stops you from reading and experimenting, just take everything you read and hear cum grano salis - including what I say.

2 Likes

Welcome @Irenburg I do sympathize with your problems and hope @abhishek solution of re-sourcing the app improves the app launch speed. I agree that boot times are more to do with bragging rights rather than everyday practicality as @Mina implies. You can see below the leap in performance in percentage terms, comparing two notebooks of different vintage regarding chip and drive but - I too am not bothered by the odd 20 seconds – hope you will note how my 13 year old HP G60 HDD Notebook running Trisquel 8.0 gnulinux (based on ubuntu 16.04) compared to your newer machine but still with HDD – being slowed down by ubuntu 20. :confused:
LibreOffice Writer and gimp take about 2secs to launch. Perhaps @abhishek can confirm that ubuntu 20 is indeed slower than 16…? Ah; progress! :face_with_raised_eyebrow:

Intel® Core™2 Duo CPU T5800 @ 2.00GHz Hitachi 2.5 inch SATA hard disk drive :blush:
Very slow by today’s standards but I am told that it can be replaced with much faster drive? :face_with_thermometer:
Fast enough for my needs as I also have a much faster more modern Dell Latitude E6420 i7 – 256GB SSD dual boot ubuntu 16.04 with Win10-Pro - though not used hardly at all as this has a smaller screen and no number pad.

Ancient HP-G60-Notebook-PC:~$ systemd-analyze
Startup finished in 11.976s (kernel) + 22.196s (userspace) = 34.173s
Slightly faster than @abhishek Dell XPS Ubuntu edition which uses SSD – 35.704s; explain that please as I have no idea? What about my Dell Latitude speeds listed below….? :zipper_mouth_face:

ubuntu 16.04 dell-Latitude-E6420:~$ systemd-analyze
Startup finished in 3.246s (kernel) + 10.378s (userspace) = 13.625s

Ancient HP-G60-Notebook-PC:~$ systemd-analyze blame
7.342s dev-sda1.device
5.630s apparmor.service
3.301s NetworkManager.service
2.558s lvm2-monitor.service
2.181s systemd-tmpfiles-setup-dev.service
1.609s systemd-udevd.service
1.598s accounts-daemon.service
1.572s keyboard-setup.service
1.427s grub-common.service
1.412s lightdm.service
1.258s systemd-journald.service
1.221s wpa_supplicant.service
1.220s systemd-modules-load.service
1.105s usb_modeswitch@2-1.service
982ms console-setup.service
846ms avahi-daemon.service
805ms home.mount
801ms ofono.service
706ms resolvconf.service
686ms rsyslog.service
677ms console-kit-log-system-start.service
668ms systemd-random-seed.service
619ms systemd-logind.service

dell-Latitude-E6420:~$ systemd-analyze blame
5.660s NetworkManager-wait-online.service
3.039s apt-daily.service
1.729s fwupd.service
781ms dev-sda5.device
630ms networking.service
617ms vboxdrv.service
548ms apt-daily-upgrade.service
399ms snapd.service
380ms apparmor.service
325ms dev-loop0.device
320ms grub-common.service
318ms dev-loop1.device
300ms irqbalance.service
229ms ModemManager.service
223ms ondemand.service
222ms apport.service
212ms speech-dispatcher.service
183ms accounts-daemon.service
178ms lightdm.service
130ms alsa-restore.service
116ms NetworkManager.service
106ms console-setup.service
102ms gpu-manager.service

Academic interesting nitty-gritty stuff :face_with_monocle: – Hope @abhishek will include the involvement of the dreaded google and that backdoor in his write up on Snap…?

@abhishek @Andy2 @easyt50 @Mina @clatterfordslim
Hello Guys it’s been a while :sweat_smile:.
I was experimenting somethings so I can say what I concluded.
Firstly I want to thanks all of you guys I really appreciated your help, and now let’s begin what i did to solve my issue :
What I did is just installing Ubuntu 20.04 LTS, and it’s running pretty well and here are the steps I followed:

  1. Download Ubuntu 20.04 LTS.
  2. Check that your drive isn’t the problem ( HDD or SSD ), you can do this by burning the ISO file into a flash drive, and try Ubuntu from it, try opening Apps, surf the internet.
  3. if it’s working fine than the problem isn’t your drive
  4. install Ubuntu.
  5. as @abhishek said, the snap Apps are slow in loading so try to avoid them as much as possible.
  6. optional : consider buying an SSD ( I’m buying one too ) this will improve your experience ( Use SSD for the system ).

This what i did to fix my problem, I didn’t try this with Ubuntu 20.10 cause that’s a rolling release, it may be more buggy, so I suggest installing the LTS release cause it’s the stable one.
Hope this help.

4 Likes